summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json17
-rw-r--r--glpi-fedora-autoloader.php2
-rw-r--r--glpi.spec15
3 files changed, 24 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 71dcb81..d1c3ee8 100644
--- a/composer.json
+++ b/composer.json
@@ -32,7 +32,8 @@
"paragonie/random_compat": "^2.0",
"monolog/monolog": "^1.23",
"sebastian/diff": "^1.4 || ^2.0 || ^3.0",
- "zendframework/zend-console": "^2.7"
+ "zendframework/zend-console": "^2.7",
+ "elvanto/litemoji": "^1.4"
},
"require-dev": {
"guzzlehttp/guzzle": "~6",
@@ -43,7 +44,8 @@
"atoum/atoum": "^3.3",
"atoum/telemetry-extension": "^1.0",
"sensiolabs/security-checker": "^4.1",
- "fzaninotto/Faker": "^1.7"
+ "fzaninotto/Faker": "^1.7",
+ "jakub-onderka/php-parallel-lint": "^1.0"
},
"suggest": {
"ext-ldap": "Used ot provide LDAP authentication and synchronization",
@@ -56,13 +58,14 @@
}
},
"scripts": {
- "testdb": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/database",
- "testfunc": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/functionnal/",
- "testunits": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage -d tests/units",
- "testweb": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/web",
- "testldap": "php -d memory_limit=512M vendor/bin/atoum --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/LDAP",
+ "testdb": "php vendor/bin/atoum -p 'php -d memory_limit=512M' --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/database",
+ "testfunc": "php vendor/bin/atoum -p 'php -d memory_limit=512M' --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/functionnal/",
+ "testunits": "php vendor/bin/atoum -p 'php -d memory_limit=512M' --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage -d tests/units",
+ "testweb": "php vendor/bin/atoum -p 'php -d memory_limit=512M' --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/web",
+ "testldap": "php vendor/bin/atoum -p 'php -d memory_limit=512M' --debug --force-terminal --use-dot-report --configurations tests/telemetry.php --bootstrap-file tests/bootstrap.php --no-code-coverage --max-children-number 1 -d tests/LDAP",
"csp": "vendor/bin/phpcs --parallel=500 -p --standard=vendor/glpi-project/coding-standard/GlpiStandard/ --ignore=/vendor/,/plugins/,/files/,/lib/,/config/,/tests/config,/css/tiny_mce,/.git ./",
"cs": "vendor/bin/phpcs -d memory_limit=512M -p --standard=vendor/glpi-project/coding-standard/GlpiStandard/ --ignore=/vendor/,/plugins/,/files/,/lib/,/config/,/tests/config,/css/tiny_mce,/.git ./",
+ "lint": "vendor/bin/parallel-lint --exclude files --exclude plugins --exclude vendor --exclude tools/vendor .",
"post-install-cmd": "@php -r \"file_put_contents('.composer.hash', sha1_file('composer.lock'));\"",
"post-update-cmd": "@php -r \"file_put_contents('.composer.hash', sha1_file('composer.lock'));\""
}
diff --git a/glpi-fedora-autoloader.php b/glpi-fedora-autoloader.php
index 9e8f6ce..cc10ef1 100644
--- a/glpi-fedora-autoloader.php
+++ b/glpi-fedora-autoloader.php
@@ -43,6 +43,8 @@ require_once "$vendor/Fedora/Autoloader/autoload.php";
"$vendor/random_compat/autoload.php",
// "monolog/monolog": "^1.23",
"$vendor/Monolog/autoload.php",
+// "elvanto/litemoji": "^1.4"
+ "$vendor/LitEmoji/autoload.php",
// "sebastian/diff": "^1.4 || ^2.0 || ^3.0"
[
"$vendor/SebastianBergmann/Diff3/autoload.php",
diff --git a/glpi.spec b/glpi.spec
index e3c3dba..c31bd99 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -56,7 +56,7 @@ Name: %{gh_project}
#global upstream_prever RC2
# use 9.3.0~RC2 < 9.3 (for plugin compatibility check)
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -103,10 +103,11 @@ BuildRequires: (php-composer(michelf/php-markdown) >= 1.6 with php
BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
BuildRequires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
BuildRequires: (php-composer(monolog/monolog) >= 1.23 with php-composer(monolog/monolog) < 2)
+BuildRequires: (php-composer(elvanto/litemoji) >= 1.4 with php-composer(elvanto/litemoji) < 2)
# requires-dev
BuildRequires: (php-composer(guzzlehttp/guzzle) >= 6 with php-composer(guzzlehttp/guzzle) < 7)
BuildRequires: (php-composer(atoum/atoum) >= 3.3 with php-composer(atoum/atoum) < 4)
-# remirepo:35
+# remirepo:37
%else
BuildRequires: php-composer(iamcal/lib_autolink) < 2
BuildRequires: php-composer(iamcal/lib_autolink) >= 1.7
@@ -136,6 +137,8 @@ BuildRequires: php-composer(paragonie/random_compat) < 3
BuildRequires: php-composer(paragonie/random_compat) >= 2.0
BuildRequires: php-composer(monolog/monolog) < 2
BuildRequires: php-composer(monolog/monolog) >= 1.23
+BuildRequires: php-composer(elvanto/litemoji) < 2
+BuildRequires: php-composer(elvanto/litemoji) >= 1.4
# requires-dev
BuildRequires: php-composer(guzzlehttp/guzzle) < 7
BuildRequires: php-composer(guzzlehttp/guzzle) >= 6
@@ -207,7 +210,8 @@ Requires: (php-composer(michelf/php-markdown) >= 1.6 with php
Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
Requires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
Requires: (php-composer(monolog/monolog) >= 1.23 with php-composer(monolog/monolog) < 2)
-# remirepo:30
+Requires: (php-composer(elvanto/litemoji) >= 1.4 with php-composer(elvanto/litemoji) < 2)
+# remirepo:32
%else
Requires: php-composer(iamcal/lib_autolink) < 2
Requires: php-composer(iamcal/lib_autolink) >= 1.7
@@ -237,6 +241,8 @@ Requires: php-composer(paragonie/random_compat) < 3
Requires: php-composer(paragonie/random_compat) >= 2.0
Requires: php-composer(monolog/monolog) < 2
Requires: php-composer(monolog/monolog) >= 1.23
+Requires: php-composer(elvanto/litemoji) < 2
+Requires: php-composer(elvanto/litemoji) >= 1.4
%endif
Requires: gnu-free-sans-fonts
%if 0%{?fedora} || 0%{?rhel} >= 8
@@ -589,6 +595,9 @@ fi
%changelog
+* Tue Nov 6 2018 Remi Collet <remi@remirepo.net> - 9.3.2-3
+- add missing dependency on elvanto/litemoji
+
* Fri Nov 2 2018 Remi Collet <remi@remirepo.net> - 9.3.2-2
- version 9.3.2 conflicts with glpi-fusioninventory < 1:9.3+1.2
see https://github.com/glpi-project/glpi/issues/4837