summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--4178.patch24
-rw-r--r--composer.json5
-rw-r--r--glpi-fedora-autoloader.php5
-rw-r--r--glpi.spec23
4 files changed, 23 insertions, 34 deletions
diff --git a/4178.patch b/4178.patch
deleted file mode 100644
index c860520..0000000
--- a/4178.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From f4c6a0e0688cfb95afb695f0b26179df3e617e8d Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 14 Jun 2018 14:02:13 +0200
-Subject: [PATCH] cleanup RPM stuff (moved to downstream.php)
-
----
- inc/based_config.php | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/inc/based_config.php b/inc/based_config.php
-index da03ab70c0..834d4ea4ef 100644
---- a/inc/based_config.php
-+++ b/inc/based_config.php
-@@ -43,9 +43,7 @@
- }
-
- // If this file exists, it is load
--if (!is_dir(GLPI_ROOT. '/config') && file_exists('/etc/glpi/local_define.php')) { // Relocated (Linux only)
-- require_once '/etc/glpi/local_define.php';
--} else if (file_exists(GLPI_ROOT. '/config/local_define.php')) {
-+if (file_exists(GLPI_ROOT. '/config/local_define.php')) {
- require_once GLPI_ROOT. '/config/local_define.php';
- }
-
diff --git a/composer.json b/composer.json
index e0f408c..71dcb81 100644
--- a/composer.json
+++ b/composer.json
@@ -31,11 +31,12 @@
"true/punycode": "^2.1",
"paragonie/random_compat": "^2.0",
"monolog/monolog": "^1.23",
- "sebastian/diff": "^1.4 || ^2.0 || ^3.0"
+ "sebastian/diff": "^1.4 || ^2.0 || ^3.0",
+ "zendframework/zend-console": "^2.7"
},
"require-dev": {
"guzzlehttp/guzzle": "~6",
- "glpi-project/coding-standard": "^0.7.0",
+ "glpi-project/coding-standard": "^0.7.1",
"consolidation/robo": "^1.0",
"natxet/CssMin": "^3.0",
"patchwork/jsqueeze": "^2.0",
diff --git a/glpi-fedora-autoloader.php b/glpi-fedora-autoloader.php
index 534ac96..9e8f6ce 100644
--- a/glpi-fedora-autoloader.php
+++ b/glpi-fedora-autoloader.php
@@ -30,6 +30,11 @@ require_once "$vendor/Fedora/Autoloader/autoload.php";
"$vendor/Zend/Serializer/autoload.php",
"$vendor/Zend/autoload.php",
],
+ // "zendframework/zend-console": "^2.7"
+ [
+ "$vendor/Zend/Console/autoload.php",
+ "$vendor/Zend/autoload.php",
+ ],
// "michelf/php-markdown": "^1.6",
"$vendor/Michelf/markdown-autoload.php",
// "true/punycode": "^2.1",
diff --git a/glpi.spec b/glpi.spec
index 2ab8857..b909d04 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 222fd2dc5d8a301bd4b691f760200ce10ae8e34f
+%global gh_commit d5017d7de5636bfe5a2f13e64c685423723f7f33
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -47,11 +47,11 @@
%endif
Name: %{gh_project}
-%global upstream_version 9.3
-%global upstream_prever RC2
+%global upstream_version 9.3.0
+#global upstream_prever RC2
# use 9.3.0~RC2 < 9.3 (for plugin compatibility check)
-Version: %{upstream_version}.0%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -71,8 +71,6 @@ Source6: %{name}-minify.php
# Override PHP configuration for php-fpm
Source7: %{name}-user.ini
-Patch0: https://patch-diff.githubusercontent.com/raw/glpi-project/glpi/pull/4178.patch
-
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php-cli
@@ -95,6 +93,7 @@ BuildRequires: (php-composer(sebastian/diff) >= 1.4 with php
BuildRequires: (php-autoloader(zendframework/zend-cache) >= 2.8 with php-autoloader(zendframework/zend-cache) < 3)
BuildRequires: (php-autoloader(zendframework/zend-i18n) >= 2.8 with php-autoloader(zendframework/zend-i18n) < 3)
BuildRequires: (php-autoloader(zendframework/zend-serializer) >= 2.8 with php-autoloader(zendframework/zend-serializer) < 3)
+BuildRequires: (php-autoloader(zendframework/zend-console) >= 2.7 with php-autoloader(zendframework/zend-console) < 3)
BuildRequires: (php-composer(michelf/php-markdown) >= 1.6 with php-composer(michelf/php-markdown) < 2)
BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
BuildRequires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
@@ -122,6 +121,8 @@ BuildRequires: php-composer(zendframework/zend-i18n) < 3
BuildRequires: php-composer(zendframework/zend-i18n) >= 2.8
BuildRequires: php-composer(zendframework/zend-serializer) < 3
BuildRequires: php-composer(zendframework/zend-serializer) >= 2.8
+BuildRequires: php-composer(zendframework/zend-console) < 3
+BuildRequires: php-composer(zendframework/zend-console) >= 2.7
BuildRequires: php-composer(michelf/php-markdown) < 2
BuildRequires: php-composer(michelf/php-markdown) >= 1.6
BuildRequires: php-composer(true/punycode) < 3
@@ -196,6 +197,7 @@ Requires: (php-composer(sebastian/diff) >= 1.4 with php
Requires: (php-autoloader(zendframework/zend-cache) >= 2.8 with php-autoloader(zendframework/zend-cache) < 3)
Requires: (php-autoloader(zendframework/zend-i18n) >= 2.8 with php-autoloader(zendframework/zend-i18n) < 3)
Requires: (php-autoloader(zendframework/zend-serializer) >= 2.8 with php-autoloader(zendframework/zend-serializer) < 3)
+Requires: (php-autoloader(zendframework/zend-console) >= 2.7 with php-autoloader(zendframework/zend-console) < 3)
Requires: (php-composer(michelf/php-markdown) >= 1.6 with php-composer(michelf/php-markdown) < 2)
Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
Requires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
@@ -219,6 +221,8 @@ Requires: php-composer(zendframework/zend-i18n) < 3
Requires: php-composer(zendframework/zend-i18n) >= 2.8
Requires: php-composer(zendframework/zend-serializer) < 3
Requires: php-composer(zendframework/zend-serializer) >= 2.8
+Requires: php-composer(zendframework/zend-console) < 3
+Requires: php-composer(zendframework/zend-console) >= 2.7
Requires: php-composer(zendframework/zend-loader)
Requires: php-composer(michelf/php-markdown) < 2
Requires: php-composer(michelf/php-markdown) >= 1.6
@@ -290,7 +294,6 @@ techniciens grâce à une maintenance plus cohérente.
%prep
%setup -q -n %{name}-%{gh_commit}
-%patch0 -p1
grep %{upstream_version} inc/define.php
@@ -589,6 +592,10 @@ fi
%changelog
+* Thu Jun 28 2018 Remi Collet <remi@remirepo.net> - 9.3.0-1
+- update to 9.3.0 GA
+- add dependency on zend-console
+
* Wed Jun 20 2018 Remi Collet <remi@remirepo.net> - 9.3.0~RC2-4
- drop dependency on initscripts #1592356