summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--glpi-0.85-config_path.php34
-rw-r--r--glpi-0.85-cron.patch29
-rw-r--r--glpi-dev.spec26
3 files changed, 79 insertions, 10 deletions
diff --git a/glpi-0.85-config_path.php b/glpi-0.85-config_path.php
new file mode 100644
index 0000000..bc97248
--- /dev/null
+++ b/glpi-0.85-config_path.php
@@ -0,0 +1,34 @@
+<?php
+// for Redhat/Fedora RPM defaults
+
+// Config
+define('GLPI_CONFIG_DIR', '/etc/glpi');
+
+// Runtime Data
+define('GLPI_DOC_DIR', '/var/lib/glpi/files');
+define('GLPI_DUMP_DIR', '/var/lib/glpi/files/_dumps');
+define('GLPI_CACHE_DIR', '/var/lib/glpi/files/_cache/');
+define('GLPI_CRON_DIR', '/var/lib/glpi/files/_cron');
+define('GLPI_SESSION_DIR', '/var/lib/glpi/files/_sessions');
+define('GLPI_PLUGIN_DOC_DIR', '/var/lib/glpi/files/_plugins');
+define('GLPI_LOCK_DIR', '/var/lib/glpi/files/_lock/');
+define('GLPI_GRAPH_DIR', '/var/lib/glpi/files/_graphs/');
+define('GLPI_TMP_DIR', '/var/lib/glpi/files/_tmp/');
+define('GLPI_RSS_DIR', '/var/lib/glpi/files/_rss/');
+define('GLPI_UPLOAD_DIR', '/var/lib/glpi/files/_uploads/');
+define('GLPI_PICTURE_DIR', '/var/lib/glpi/files/_pictures/');
+
+// Log
+define('GLPI_LOG_DIR', '/var/log/glpi');
+
+// System libraries
+define('GLPI_PHPMAILER_DIR', 'PHPMailer');
+define('GLPI_EZC_BASE', 'ezc/Base/base.php');
+define('GLPI_PHPCAS', 'CAS.php');
+define('GLPI_HTMLAWED', 'htmLawed/htmLawed.php');
+define('GLPI_ZEND_PATH', '/usr/share/php/Zend');
+define('GLPI_SIMPLEPIE_PATH', '/usr/share/php/php-simplepie');
+define('GLPI_TCPDF_DIR', '/usr/share/php/tcpdf');
+
+// Fonts
+define('GLPI_FONT_FREESANS', '/usr/share/fonts/gnu-free/FreeSans.ttf');
diff --git a/glpi-0.85-cron.patch b/glpi-0.85-cron.patch
new file mode 100644
index 0000000..511fc3c
--- /dev/null
+++ b/glpi-0.85-cron.patch
@@ -0,0 +1,29 @@
+diff -up install/install.php.rpm install/install.php
+--- install/install.php.rpm 2014-12-17 13:36:22.420558338 +0100
++++ install/install.php 2014-12-17 13:38:45.278209044 +0100
+@@ -345,6 +345,11 @@ function step4 ($databasename, $newdatab
+ $query = "UPDATE `glpi_users`
+ SET `language` = NULL";
+ $DB->queryOrDie($query, "4203");
++
++ // RPM provides a good system cron
++ Config::setConfigurationValues('core', array('cron_limit' => '3'));
++ $query = "UPDATE `glpi_crontasks` SET `mode`=2 WHERE `name`!='watcher' AND (`allowmode` & 2)";
++ $DB->queryOrDie($query, "4203");
+ }
+
+ //Check if the port is in url
+diff -up install/update.php.rpm install/update.php
+--- install/update.php.rpm 2014-12-11 14:16:55.000000000 +0100
++++ install/update.php 2014-12-17 13:36:22.420558338 +0100
+@@ -803,6 +803,10 @@ function updateDbUpTo031() {
+ $plugin = new Plugin();
+ $plugin->unactivateAll();
+
++ // RPM provides a good system cron
++ $query = "UPDATE `glpi_crontasks` SET `mode`=2 WHERE `name`!='watcher' AND (`allowmode` & 2)";
++ $DB->queryOrDie($query);
++
+ DBmysql::optimize_tables($migration);
+
+ return $ret;
diff --git a/glpi-dev.spec b/glpi-dev.spec
index 4ca65ba..3911ea1 100644
--- a/glpi-dev.spec
+++ b/glpi-dev.spec
@@ -27,23 +27,23 @@
%endif
Name: glpi
-Version: 0.84.8
-Release: 2%{?dist}
+Version: 0.85.1
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
Group: Applications/Internet
License: GPLv2+ and GPLv3+
URL: http://www.glpi-project.org/
-Source0: https://forge.indepnet.net/attachments/download/1873/glpi-0.84.8.tar.gz
+Source0: https://forge.indepnet.net/attachments/download/1928/glpi-0.85.1.tar.gz
Source1: glpi-httpd.conf
-Source2: glpi-config_path.php
+Source2: glpi-0.85-config_path.php
Source3: glpi-logrotate
Source4: glpi-nginx.conf
# Switch all internal cron tasks to system
-Patch0: glpi-0.84-cron.patch
+Patch0: glpi-0.85-cron.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -73,8 +73,8 @@ Requires: php-mysqli
Requires: php-pcre
Requires: php-session
Requires: php-xml
-Requires: php-pear(Cache_Lite) >= 1.7.4
Requires: php-PHPMailer
+Requires: php-tcpdf
Requires: php-pear-CAS >= 1.2.0
Requires: php-htmLawed
Requires: php-simplepie
@@ -124,7 +124,7 @@ techniciens grâce à une maintenance plus cohérente.
%prep
%setup -q -n glpi
-%patch0 -p0
+%patch0 -p0 -b rpm
find . -name \*.orig -exec rm {} \; -print
@@ -132,12 +132,12 @@ find . -name \*.orig -exec rm {} \; -print
find lib -name \*.swf -exec rm {} \; -print
# Use system lib
-rm -rf lib/cache_lite
rm -rf lib/phpmailer
rm -rf lib/phpcas
rm -rf lib/htmlawed
rm -rf lib/Zend
rm -rf lib/simplepie
+rm -rf lib/tcpdf
rm -rf lib/ezcomponents
%if 0%{?fedora} < 9 && 0%{?rhel} < 6
@@ -149,7 +149,6 @@ cp %{SOURCE2} config/config_path.php
%endif
mv lib/tiny_mce/license.txt LICENSE.tiny_mce
-mv lib/extjs/gpl-3.0.txt LICENSE.extjs
mv lib/icalcreator/lgpl.txt LICENSE.icalcreator
rm scripts/glpi_cron_*.sh
@@ -161,7 +160,7 @@ done
cat >cron <<EOF
# GLPI core
-# Run cron from to execute task even when no user connected
+# Run cron to execute task even when no user connected
*/3 * * * * apache %{_bindir}/php %{_datadir}/%{name}/front/cron.php
EOF
@@ -308,6 +307,13 @@ fi
%changelog
+* Wed Dec 17 2014 Remi Collet <remi@fedoraproject.org> - 0.85.1-1
+- update to 0.85.1
+ 0.85 https://forge.indepnet.net/versions/539
+ 0.85.1 https://forge.indepnet.net/versions/1071
+- drop dependency on pear/Cache_Lite
+- add dependency on php-tcpdf
+
* Fri Nov 7 2014 Remi Collet <remi@fedoraproject.org> - 0.84.8-2
- use httpd_var_lib_t selinux context for /var/lib/glpi
- don't rely on system selinux policy in EPEL-7