summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--glpi-9.1-pr1056.patch30
-rw-r--r--glpi-9.1-pr1058.patch67
-rw-r--r--glpi-dev.spec11
3 files changed, 7 insertions, 101 deletions
diff --git a/glpi-9.1-pr1056.patch b/glpi-9.1-pr1056.patch
deleted file mode 100644
index 85593c6..0000000
--- a/glpi-9.1-pr1056.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From e58360e8f377e95ef96711b8b4466b0a7c066a89 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 26 Sep 2016 08:45:22 +0200
-Subject: [PATCH] ensure GLPI autoloader always first in the stack
-
----
- inc/autoload.function.php | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/inc/autoload.function.php b/inc/autoload.function.php
-index 12fc186..3fce416 100644
---- a/inc/autoload.function.php
-+++ b/inc/autoload.function.php
-@@ -336,12 +336,12 @@ function glpi_autoload($classname) {
- }
- }
-
--// Use spl autoload to allow stackable autoload.
--spl_autoload_register('glpi_autoload');
--
- // composer autoload
- $autoload = dirname(__DIR__) . '/vendor/autoload.php';
- if (!file_exists($autoload)) {
- die('Run "composer install --no-dev" in the glpi tree');
- }
- require_once $autoload;
-+
-+// Use spl autoload to allow stackable autoload.
-+spl_autoload_register('glpi_autoload', false, true);
-\ No newline at end of file
diff --git a/glpi-9.1-pr1058.patch b/glpi-9.1-pr1058.patch
deleted file mode 100644
index e81cced..0000000
--- a/glpi-9.1-pr1058.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From ef8e4cb98cbd0e2c59b0059141559178e840b882 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Mon, 26 Sep 2016 11:07:53 +0200
-Subject: [PATCH] fix 1057, ensure tests use correct configuration
-
----
- .travis.yml | 3 +--
- phpunit.xml.dist | 1 +
- tests/bootstrap.php | 8 ++++----
- tests/router.php | 4 ++++
- 4 files changed, 10 insertions(+), 6 deletions(-)
- create mode 100644 tests/router.php
-
-diff --git a/.travis.yml b/.travis.yml
-index a4401e8..ffdef3a 100644
---- a/.travis.yml
-+++ b/.travis.yml
-@@ -8,8 +8,7 @@ before_script:
- - composer install --no-dev
- - mysql -u root -e 'create database glpitest;'
- - php tools/cliinstall.php --lang=en_US --db=glpitest --user=root --tests
-- - cp tests/config_db.php config/
-- - php -S localhost:8088 > /dev/null 2>&1 &
-+ - php -S localhost:8088 tests/router.php &>/dev/null &
-
- script:
- - mysql -u root -e 'select version();'
-diff --git a/phpunit.xml.dist b/phpunit.xml.dist
-index a25f179..e7d33da 100644
---- a/phpunit.xml.dist
-+++ b/phpunit.xml.dist
-@@ -16,5 +16,6 @@
- <php>
- <const name="GLPI_CONFIG_DIR" value="./tests" />
- <const name="GLPI_LOG_DIR" value="./tests/files/_log" />
-+ <const name="GLPI_URI" value="http://localhost:8088" />
- </php>
- </phpunit>
-diff --git a/tests/bootstrap.php b/tests/bootstrap.php
-index bfbe957..c4dbf3f 100644
---- a/tests/bootstrap.php
-+++ b/tests/bootstrap.php
-@@ -137,10 +137,10 @@ function loadDataset() {
- $CFG_GLPI['root_doc'] = '/glpi';
-
- // need to set theses in DB, because tests for API use http call and this bootstrap file is not called
-- Config::setConfigurationValues('core', ['url_base' => 'http://localhost:8088',
-- 'url_base_api' => 'http://localhost:8088/apirest.php']);
-- $CFG_GLPI['url_base'] = 'http://localhost:8088';
-- $CFG_GLPI['url_base_api'] = 'http://localhost:8088/apirest.php';
-+ Config::setConfigurationValues('core', ['url_base' => GLPI_URI,
-+ 'url_base_api' => GLPI_URI . '/apirest.php']);
-+ $CFG_GLPI['url_base'] = GLPI_URI;
-+ $CFG_GLPI['url_base_api'] = GLPI_URI . '/apirest.php';
-
- @mkdir(GLPI_LOG_DIR, 0755, true);
-
-diff --git a/tests/router.php b/tests/router.php
-new file mode 100644
-index 0000000..8b39e8c
---- /dev/null
-+++ b/tests/router.php
-@@ -0,0 +1,4 @@
-+<?php
-+define('GLPI_CONFIG_DIR', __DIR__);
-+
-+return false;
diff --git a/glpi-dev.spec b/glpi-dev.spec
index bffd5b2..af0b340 100644
--- a/glpi-dev.spec
+++ b/glpi-dev.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 80328baf38e2d6fe6cf269b43ed0edc80c64d89d
+%global gh_commit 3dedf3453ae2f4b3e0e26772e7ce00182aeb4e5d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -42,9 +42,9 @@
%endif
Name: %{gh_project}
-Version: 9.1.1
+Version: 9.1.2
%global schema 9.1.1
-Release: 3%{?dist}
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -367,7 +367,7 @@ done
cp %{SOURCE12} config/config_path.php
: Run upstream test suite
-php tools/cliinstall.php --host=127.0.0.1:3308 --db=glpitest --user=root --tests --force --lang=en_US || RET=1
+php tools/cliinstall.php --host=127.0.0.1:3308 --db=glpitest --user=root --tests --force --lang=en_GB || RET=1
%{_bindir}/phpunit --verbose || RET=1
@@ -466,6 +466,9 @@ fi
%changelog
+* Mon Jan 23 2017 Johan Cwiklinski <jcwiklinski AT teclib DOT com> - 9.1.2-1
+- update to 9.1.2
+
* Mon Jan 9 2017 Remi Collet <remi@fedoraproject.org> - 9.1.1-3
- use new tcpdf classmap autoloader