summaryrefslogtreecommitdiffstats
path: root/glpi.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-28 13:04:03 +0200
committerRemi Collet <remi@remirepo.net>2018-06-28 13:04:03 +0200
commit3ef4afa636650ff6a23c9fdfdb26c64414313531 (patch)
treece4946ea024e170be89b92ab47daf6dba1c1e90f /glpi.spec
parente32a45f61d271db7fc5fe6cd26e4e1d58e03f113 (diff)
v9.3.0
Diffstat (limited to 'glpi.spec')
-rw-r--r--glpi.spec23
1 files changed, 15 insertions, 8 deletions
diff --git a/glpi.spec b/glpi.spec
index 2ab8857..b909d04 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 222fd2dc5d8a301bd4b691f760200ce10ae8e34f
+%global gh_commit d5017d7de5636bfe5a2f13e64c685423723f7f33
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -47,11 +47,11 @@
%endif
Name: %{gh_project}
-%global upstream_version 9.3
-%global upstream_prever RC2
+%global upstream_version 9.3.0
+#global upstream_prever RC2
# use 9.3.0~RC2 < 9.3 (for plugin compatibility check)
-Version: %{upstream_version}.0%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -71,8 +71,6 @@ Source6: %{name}-minify.php
# Override PHP configuration for php-fpm
Source7: %{name}-user.ini
-Patch0: https://patch-diff.githubusercontent.com/raw/glpi-project/glpi/pull/4178.patch
-
BuildArch: noarch
BuildRequires: gettext
BuildRequires: php-cli
@@ -95,6 +93,7 @@ BuildRequires: (php-composer(sebastian/diff) >= 1.4 with php
BuildRequires: (php-autoloader(zendframework/zend-cache) >= 2.8 with php-autoloader(zendframework/zend-cache) < 3)
BuildRequires: (php-autoloader(zendframework/zend-i18n) >= 2.8 with php-autoloader(zendframework/zend-i18n) < 3)
BuildRequires: (php-autoloader(zendframework/zend-serializer) >= 2.8 with php-autoloader(zendframework/zend-serializer) < 3)
+BuildRequires: (php-autoloader(zendframework/zend-console) >= 2.7 with php-autoloader(zendframework/zend-console) < 3)
BuildRequires: (php-composer(michelf/php-markdown) >= 1.6 with php-composer(michelf/php-markdown) < 2)
BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
BuildRequires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
@@ -122,6 +121,8 @@ BuildRequires: php-composer(zendframework/zend-i18n) < 3
BuildRequires: php-composer(zendframework/zend-i18n) >= 2.8
BuildRequires: php-composer(zendframework/zend-serializer) < 3
BuildRequires: php-composer(zendframework/zend-serializer) >= 2.8
+BuildRequires: php-composer(zendframework/zend-console) < 3
+BuildRequires: php-composer(zendframework/zend-console) >= 2.7
BuildRequires: php-composer(michelf/php-markdown) < 2
BuildRequires: php-composer(michelf/php-markdown) >= 1.6
BuildRequires: php-composer(true/punycode) < 3
@@ -196,6 +197,7 @@ Requires: (php-composer(sebastian/diff) >= 1.4 with php
Requires: (php-autoloader(zendframework/zend-cache) >= 2.8 with php-autoloader(zendframework/zend-cache) < 3)
Requires: (php-autoloader(zendframework/zend-i18n) >= 2.8 with php-autoloader(zendframework/zend-i18n) < 3)
Requires: (php-autoloader(zendframework/zend-serializer) >= 2.8 with php-autoloader(zendframework/zend-serializer) < 3)
+Requires: (php-autoloader(zendframework/zend-console) >= 2.7 with php-autoloader(zendframework/zend-console) < 3)
Requires: (php-composer(michelf/php-markdown) >= 1.6 with php-composer(michelf/php-markdown) < 2)
Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
Requires: (php-composer(paragonie/random_compat) >= 2.0 with php-composer(paragonie/random_compat) < 3)
@@ -219,6 +221,8 @@ Requires: php-composer(zendframework/zend-i18n) < 3
Requires: php-composer(zendframework/zend-i18n) >= 2.8
Requires: php-composer(zendframework/zend-serializer) < 3
Requires: php-composer(zendframework/zend-serializer) >= 2.8
+Requires: php-composer(zendframework/zend-console) < 3
+Requires: php-composer(zendframework/zend-console) >= 2.7
Requires: php-composer(zendframework/zend-loader)
Requires: php-composer(michelf/php-markdown) < 2
Requires: php-composer(michelf/php-markdown) >= 1.6
@@ -290,7 +294,6 @@ techniciens grâce à une maintenance plus cohérente.
%prep
%setup -q -n %{name}-%{gh_commit}
-%patch0 -p1
grep %{upstream_version} inc/define.php
@@ -589,6 +592,10 @@ fi
%changelog
+* Thu Jun 28 2018 Remi Collet <remi@remirepo.net> - 9.3.0-1
+- update to 9.3.0 GA
+- add dependency on zend-console
+
* Wed Jun 20 2018 Remi Collet <remi@remirepo.net> - 9.3.0~RC2-4
- drop dependency on initscripts #1592356