summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-20 15:30:38 +0200
committerRemi Collet <remi@remirepo.net>2018-06-20 15:30:38 +0200
commit691f2980f0dd4d82cb0b2b43df81d7f19ff0cba7 (patch)
treeb1ee059f3395b48a11b90a70e07df2956cf8aea6
parentd78477811983bd2ca606586ade686cb950f44e77 (diff)
improve configuration to simply multi-glpi installation
-rw-r--r--glpi-downstream.php2
-rw-r--r--glpi-httpd.conf4
-rw-r--r--glpi-nginx.conf4
-rw-r--r--glpi.spec5
4 files changed, 13 insertions, 2 deletions
diff --git a/glpi-downstream.php b/glpi-downstream.php
index 3be9964..028f71e 100644
--- a/glpi-downstream.php
+++ b/glpi-downstream.php
@@ -12,7 +12,7 @@
// Config
-define('GLPI_CONFIG_DIR', '/etc/glpi');
+define('GLPI_CONFIG_DIR', (getenv('GLPI_CONFIG_DIR') ?: '/etc/glpi'));
if (file_exists(GLPI_CONFIG_DIR . '/local_define.php')) {
require_once GLPI_CONFIG_DIR . '/local_define.php';
diff --git a/glpi-httpd.conf b/glpi-httpd.conf
index ddafdb4..ea3466d 100644
--- a/glpi-httpd.conf
+++ b/glpi-httpd.conf
@@ -1,5 +1,9 @@
Alias /glpi /usr/share/glpi
+# Redirect configuration for multi-glpi installation
+# You can set this value in each vhost configuration
+#SetEnv GLPI_CONFIG_DIR /etc/glpi
+
<Directory /usr/share/glpi>
Options None
AllowOverride Limit Options FileInfo
diff --git a/glpi-nginx.conf b/glpi-nginx.conf
index 68ae1bf..db547bc 100644
--- a/glpi-nginx.conf
+++ b/glpi-nginx.conf
@@ -21,6 +21,10 @@ location /glpi/ {
deny all;
}
+ # Redirect configuration for multi-glpi installation
+ # You can set this value in each vhost configuration
+ #fastcgi_param GLPI_CONFIG_DIR /etc/glpi
+
# Install is only allowed via local access (from the GLPI server).
# Add your IP address if you need it for remote installation,
# but remember to remove it after installation for security.
diff --git a/glpi.spec b/glpi.spec
index 2dc285a..b7b085b 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -44,7 +44,7 @@ Name: %{gh_project}
%global upstream_prever RC2
# use 9.3.0~RC2 < 9.3 (for plugin compatibility check)
Version: %{upstream_version}.0%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -563,6 +563,9 @@ fi
%changelog
+* Wed Jun 20 2018 Remi Collet <remi@remirepo.net> - 9.3.0~RC2-3
+- improve configuration to simply multi-glpi installation
+
* Thu Jun 14 2018 Remi Collet <remi@remirepo.net> - 9.3.0~RC2-2
- test build