summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-06 14:00:29 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-06 14:00:29 +0200
commit487ec589167e0357f3cbddd7a1e9cf50b1aa4032 (patch)
tree39550381c5c863c84f7098eb91574a6469a7c11a
parentf30cd1447b77f461dd0a459652bc03399d6d7878 (diff)
glpi: 0.90-RC2
-rw-r--r--glpi-0.90-config_path.php34
-rw-r--r--glpi-0.90-cron.patch28
-rw-r--r--glpi-dev.spec31
3 files changed, 78 insertions, 15 deletions
diff --git a/glpi-0.90-config_path.php b/glpi-0.90-config_path.php
new file mode 100644
index 0000000..39802b0
--- /dev/null
+++ b/glpi-0.90-config_path.php
@@ -0,0 +1,34 @@
+<?php
+// for Redhat/Fedora RPM defaults
+
+// Config
+define('GLPI_CONFIG_DIR', '/etc/glpi');
+
+// Runtime Data
+define('GLPI_DOC_DIR', '/var/lib/glpi/files');
+define('GLPI_CRON_DIR', '/var/lib/glpi/files/_cron');
+define('GLPI_DUMP_DIR', '/var/lib/glpi/files/_dumps');
+define('GLPI_GRAPH_DIR', '/var/lib/glpi/files/_graphs');
+define('GLPI_LOCK_DIR', '/var/lib/glpi/files/_lock');
+define('GLPI_PICTURE_DIR', '/var/lib/glpi/files/_pictures');
+define('GLPI_PLUGIN_DOC_DIR', '/var/lib/glpi/files/_plugins');
+define('GLPI_RSS_DIR', '/var/lib/glpi/files/_rss');
+define('GLPI_SESSION_DIR', '/var/lib/glpi/files/_sessions');
+define('GLPI_TMP_DIR', '/var/lib/glpi/files/_tmp');
+define('GLPI_UPLOAD_DIR', '/var/lib/glpi/files/_uploads');
+
+// Log
+define('GLPI_LOG_DIR', '/var/log/glpi');
+
+// System libraries
+define('GLPI_PHPMAILER_DIR', '/usr/share/php/PHPMailer');
+define('GLPI_EZC_BASE', '/usr/share/php/ezc/Base/base.php');
+define('GLPI_PHPCAS', '/usr/share/pear/CAS.php');
+define('GLPI_HTMLAWED', '/usr/share/php/htmLawed/htmLawed.php');
+define('GLPI_ZEND_PATH', '/usr/share/php/Zend');
+define('GLPI_SIMPLEPIE_PATH', '/usr/share/php/php-simplepie');
+define('GLPI_TCPDF_DIR', '/usr/share/php/tcpdf');
+define('GLPI_PASSWORD_COMPAT','/usr/share/php/password_compat/password.php');
+
+// Fonts
+define('GLPI_FONT_FREESANS', '/usr/share/fonts/gnu-free/FreeSans.ttf');
diff --git a/glpi-0.90-cron.patch b/glpi-0.90-cron.patch
new file mode 100644
index 0000000..7a9eba7
--- /dev/null
+++ b/glpi-0.90-cron.patch
@@ -0,0 +1,28 @@
+diff -up install/install.php.rpm install/install.php
+--- install/install.php.rpm 2014-12-17 13:36:22.420558338 +0100
++++ install/install.php 2014-12-17 13:38:45.278209044 +0100
+@@ -382,6 +382,10 @@ function step4 ($databasename, $newdatab
+ $query = "UPDATE `glpi_users`
+ SET `language` = NULL";
+ $DB->queryOrDie($query, "4203");
++
++ // RPM provides a good system cron
++ $query = "UPDATE `glpi_crontasks` SET `mode`=2 WHERE `name`!='watcher' AND (`allowmode` & 2)";
++ $DB->queryOrDie($query, "4203");
+ }
+
+ //Check if the port is in url
+diff -up install/update.php.rpm install/update.php
+--- install/update.php.rpm 2014-12-11 14:16:55.000000000 +0100
++++ install/update.php 2014-12-17 13:36:22.420558338 +0100
+@@ -818,6 +818,10 @@ function updateDbUpTo031() {
+ $plugin = new Plugin();
+ $plugin->unactivateAll();
+
++ // RPM provides a good system cron
++ $query = "UPDATE `glpi_crontasks` SET `mode`=2 WHERE `name`!='watcher' AND (`allowmode` & 2)";
++ $DB->queryOrDie($query);
++
+ DBmysql::optimize_tables($migration);
+
+ return $ret;
diff --git a/glpi-dev.spec b/glpi-dev.spec
index f8465c5..3211307 100644
--- a/glpi-dev.spec
+++ b/glpi-dev.spec
@@ -25,10 +25,11 @@
%global with_nginx 0
%global with_httpd 0
%endif
+%global prever -RC2
Name: glpi
-Version: 0.85.5
-Release: 1%{?dist}
+Version: 0.90
+Release: 0.1.RC2%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -36,15 +37,15 @@ Group: Applications/Internet
License: GPLv2+ and GPLv3+
URL: http://www.glpi-project.org/
# Upstream sources (not the github auto-generated archive)
-Source0: https://github.com/glpi-project/%{name}/releases/download/%{version}/glpi-%{version}.tar.gz
+Source0: https://github.com/glpi-project/%{name}/releases/download/%{version}%{?prever}/glpi-%{version}%{?prever}.tar.gz
Source1: glpi-httpd.conf
-Source2: glpi-0.85-config_path.php
+Source2: glpi-0.90-config_path.php
Source3: glpi-logrotate
Source4: glpi-nginx.conf
# Switch all internal cron tasks to system
-Patch0: glpi-0.85-cron.patch
+Patch0: glpi-0.90-cron.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -79,13 +80,10 @@ Requires: php-tcpdf
Requires: php-pear-CAS >= 1.2.0
Requires: php-htmLawed
Requires: php-simplepie
-Requires: php-ZendFramework2-Cache
-Requires: php-ZendFramework2-Cache-apc
-Requires: php-ZendFramework2-I18n
-Requires: php-ZendFramework2-Loader
-Requires: php-ZendFramework2-ServiceManager
-Requires: php-ZendFramework2-Stdlib
-Requires: php-ZendFramework2-Version
+Requires: php-composer(zendframework/zend-cache)
+Requires: php-composer(zendframework/zend-i18n)
+Requires: php-composer(zendframework/zend-loader)
+Requires: php-composer(zendframework/zend-version)
Requires: php-composer(ircmaxell/password-compat)
%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
Requires: php-composer(zetacomponents/graph)
@@ -287,7 +285,7 @@ fi
%defattr(-,root,root,-)
%doc *.txt LICENSE.*
-%attr(750,apache,root) %dir %{_sysconfdir}/%{name}
+%attr(770,root,apache) %dir %{_sysconfdir}/%{name}
%ghost %config(noreplace,missingok) %{_sysconfdir}/%{name}/config_db.php
%config(noreplace) %{_sysconfdir}/httpd/conf.d/glpi.conf
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
@@ -298,7 +296,7 @@ fi
# This folder can contain private information (sessions, docs, ...)
%dir %_localstatedir/lib/%{name}
-%attr(750,apache,root) %{_localstatedir}/lib/%{name}/files
+%attr(770,root,apache) %{_localstatedir}/lib/%{name}/files
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/*.php
@@ -315,11 +313,14 @@ fi
%{_datadir}/%{name}/pics
%{_datadir}/%{name}/plugins
%{_datadir}/%{name}/scripts
-%attr(750,apache,root) %dir %{_localstatedir}/log/%{name}
+%attr(770,root,apache) %dir %{_localstatedir}/log/%{name}
%dir %{_datadir}/%{name}/locales
%changelog
+* Tue Oct 6 2015 Remi Collet <remi@fedoraproject.org> - 0.90-0.1.RC2
+- update to 0.90-RC2
+
* Wed Sep 16 2015 Remi Collet <remi@fedoraproject.org> - 0.85.5-1
- update to 0.85.5
https://github.com/glpi-project/glpi/issues?q=milestone:0.85.5