summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-28 12:28:42 +0200
committerRemi Collet <remi@remirepo.net>2017-04-28 12:28:42 +0200
commitdb6feef68bdbb43ba4ca95af33fe7ea1f8eee2c5 (patch)
tree2b9003a2aa8d3331e5e802cf9864ca6f74d4cae7
parent0848d1a802f115ace5260ea5c03d7d8b9d803661 (diff)
v9.1.3
-rw-r--r--composer.json5
-rw-r--r--glpi.spec52
2 files changed, 21 insertions, 36 deletions
diff --git a/composer.json b/composer.json
index 2bce0b2..9dcb29a 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,7 @@
"iamcal/lib_autolink": "~1.7",
"phpmailer/phpmailer": "~5.2",
"sabre/vobject": "~3.4",
- "simplepie/simplepie": "~1.4.0",
+ "simplepie/simplepie": "^1.5",
"tecnickcom/tcpdf": "~6.2",
"zendframework/zend-cache": "~2.4.0",
"zendframework/zend-i18n": "~2.4.0",
@@ -35,7 +35,8 @@
"true/punycode": "^2.1"
},
"require-dev": {
- "guzzlehttp/guzzle": "~5"
+ "guzzlehttp/guzzle": "~5",
+ "phpunit/phpunit": "^4.8 || ^5.7 || ^6.0"
},
"suggest": {
"ext-ldap": "Used ot provide LDAP authentication and synchronization",
diff --git a/glpi.spec b/glpi.spec
index a8ac968..d8de5b7 100644
--- a/glpi.spec
+++ b/glpi.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 3dedf3453ae2f4b3e0e26772e7ce00182aeb4e5d
+%global gh_commit c6f470be3d4b0728333f54ed953950c14de68501
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20160923
%global gh_owner glpi-project
@@ -42,9 +42,9 @@
%endif
Name: %{gh_project}
-Version: 9.1.2
-%global schema 9.1.1
-Release: 3%{?dist}
+Version: 9.1.3
+%global schema 9.1.3
+Release: 1%{?dist}
Summary: Free IT asset management software
Summary(fr): Gestion Libre de Parc Informatique
@@ -61,12 +61,16 @@ Source3: %{name}-logrotate
Source4: %{name}-nginx.conf
Source5: %{name}-fedora-autoloader.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: gettext
%if %{with_tests}
BuildRequires: php-cli
-BuildRequires: %{_bindir}/phpunit
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
BuildRequires: mariadb-server
# Missing in mariadb
BuildRequires: hostname
@@ -82,17 +86,13 @@ BuildRequires: php-composer(iamcal/lib_autolink) >= 1.7
BuildRequires: php-composer(sabre/vobject) >= 3.4
BuildRequires: php-composer(michelf/php-markdown) >= 1.6
BuildRequires: php-composer(true/punycode) >= 2
-BuildRequires: php-composer(simplepie/simplepie) >= 1.4
+BuildRequires: php-composer(simplepie/simplepie) >= 1.5
BuildRequires: php-composer(phpmailer/phpmailer) >= 5.2
# 6.2.13 to ensure we have the classmap autoloader
BuildRequires: php-composer(tecnickcom/tcpdf) >= 6.2.13
BuildRequires: php-mysqli
BuildRequires: php-xmlrpc
-# remirepo:1
-%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
BuildRequires: php-composer(zetacomponents/graph)
-# remirepo:1
-%endif
%endif
%if %{with_nginx}
@@ -136,19 +136,13 @@ Requires: php-composer(sabre/vobject) >= 3.4
Requires: php-composer(michelf/php-markdown) >= 1.6
# upstream ask 2.1, compatibility with 2.0 ensure by autoloader
Requires: php-composer(true/punycode) >= 2.1
-Requires: php-composer(simplepie/simplepie) >= 1.4
+Requires: php-composer(simplepie/simplepie) >= 1.5
Requires: php-composer(phpmailer/phpmailer) >= 5.2
# 6.2.13 to ensure we have the classmap autoloader
Requires: php-composer(tecnickcom/tcpdf) >= 6.2.13
-# remirepo:1
-%if 0%{?fedora} >= 11 || 0%{?rhel} >= 6
Requires: php-composer(zetacomponents/graph)
Requires: gnu-free-sans-fonts
-# remirepo:3
-%else
-Requires: freefont
-%endif
Requires: %{_sysconfdir}/logrotate.d
Requires(postun): /sbin/service
Requires(post): /sbin/service
@@ -197,15 +191,7 @@ rm -rf lib/htmlawed
: bundled JS libraries
ls lib
-# remirepo:5
-%if 0%{?fedora} < 9 && 0%{?rhel} < 6
-# fix font path on old version
-sed -e '/GLPI_FONT_FREESANS/s/gnu-free/freefont/' \
- %{SOURCE2} >config/config_path.php
-%else
cp %{SOURCE2} config/config_path.php
-# remirepo:1
-%endif
mkdir vendor
sed -e "s,##DATADIR##,%{_datadir}," \
@@ -245,8 +231,6 @@ done
%install
-rm -rf %{buildroot}
-
# ===== application =====
mkdir -p %{buildroot}/%{_datadir}/%{name}
cp -a COPYING.txt *.php *.js apirest.md %{buildroot}/%{_datadir}/%{name}/
@@ -365,7 +349,7 @@ cp %{SOURCE12} config/config_path.php
: Run upstream test suite
php tools/cliinstall.php --host=127.0.0.1:3308 --db=glpitest --user=root --tests --force --lang=en_GB || RET=1
-%{_bindir}/phpunit --verbose || RET=1
+%{phpunit} --verbose || RET=1
: Cleanup
if [ -s $MYSQL_PID_FILE ]; then
@@ -379,10 +363,6 @@ exit $RET
%endif
-%clean
-rm -rf %{buildroot}
-
-
%post
%if %{useselinux}
(
@@ -424,7 +404,6 @@ fi
%files -f %{name}.lang
-%defattr(-,root,root,-)
%doc *.txt LICENSE.*
%attr(2770,root,apache) %dir %{_sysconfdir}/%{name}
@@ -462,6 +441,11 @@ fi
%changelog
+* Fri Apr 28 2017 Remi Collet <remi@remirepo.net> - 9.1.3-1
+- update to 9.1.2
+- use phpunit6 on F26+
+- raise dependency on simplepie/simplepie 1.5
+
* Sun Jan 29 2017 Remi Collet <remi@fedoraproject.org> - 9.1.2-2
- fix autoloader to allow sabre/vobject version 4