summaryrefslogtreecommitdiffstats
path: root/composer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'composer.spec')
-rw-r--r--composer.spec32
1 files changed, 25 insertions, 7 deletions
diff --git a/composer.spec b/composer.spec
index 3270136..c59333b 100644
--- a/composer.spec
+++ b/composer.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for composer
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -12,7 +12,7 @@
%bcond_without tests
-%global gh_commit 04021432f4a9cbd9351dd166b8c193f42c36a39c
+%global gh_commit f8f49191eec76f039b466aa1f161406fe43aff50
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
@@ -20,7 +20,7 @@
%global api_version 1.1.0
%global run_version 1.0.0
-%global upstream_version 1.10.21
+%global upstream_version 1.10.27
#global upstream_prever RC
%if 0
@@ -51,7 +51,6 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
BuildRequires: php-cli
-%if %{with tests}
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2)
BuildRequires: (php-composer(composer/semver) >= 1.0 with php-composer(composer/semver) < 2)
@@ -76,15 +75,16 @@ BuildRequires: %{symfony_prefix}-finder
BuildRequires: %{symfony_prefix}-filesystem
BuildRequires: %{symfony_prefix}-process
BuildRequires: php-zip
+%if %{with tests}
# From composer.json, "require-dev": {
# "symfony/phpunit-bridge": "^4.2",
# "phpspec/prophecy": "^1.10"
BuildRequires: phpunit
+%endif
# For autoloader
BuildRequires: php-composer(fedora/autoloader) >= 0.1.2
BuildRequires: php-seld-phar-utils >= 1.0.1
BuildRequires: php-PsrLog >= 1.0.0-8
-%endif
# From composer.json, "require": {
# "php": "^5.3.2 || ^7.0 || ^8.0",
@@ -173,7 +173,7 @@ Documentation: https://getcomposer.org/doc/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .rpm
+%patch -P0 -p1 -b .rpm
find . -name \*.rpm -exec rm {} \; -print
if grep -r '\.\./res'; then
@@ -256,7 +256,7 @@ ret=0
for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit \
- --filter '^((?!(testIntegration)).)*$' \
+ --filter '^((?!(testIntegration|testUpdateDoesntThrowsRuntimeExceptionIfGitCommandFailsAtFirstButIsAbleToRecover)).)*$' \
--include-path %{buildroot}%{_datadir}/php || ret=1
fi
done
@@ -278,6 +278,24 @@ exit $ret
%changelog
+* Fri Sep 29 2023 Remi Collet <remi@remirepo.net> - 1.10.27-1
+- update to 1.10.27
+
+* Thu Apr 14 2022 Remi Collet <remi@remirepo.net> - 1.10.26-1
+- update to 1.10.26
+
+* Fri Jan 21 2022 Remi Collet <remi@remirepo.net> - 1.10.25-1
+- update to 1.10.25
+
+* Fri Dec 10 2021 Remi Collet <remi@remirepo.net> - 1.10.24-1
+- update to 1.10.24
+
+* Tue Oct 5 2021 Remi Collet <remi@remirepo.net> - 1.10.23-1
+- update to 1.10.23
+
+* Tue Apr 27 2021 Remi Collet <remi@remirepo.net> - 1.10.22-1
+- update to 1.10.22
+
* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 1.10.21-1
- update to 1.10.21