summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer-rpm.patch63
-rw-r--r--composer.spec17
-rw-r--r--installed.json70
4 files changed, 65 insertions, 87 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index b44f7f2..c7e5ec9 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.4")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.5.5")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer-rpm.patch b/composer-rpm.patch
index 224503a..85536c9 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2022-08-29 07:36:37.000000000 +0200
-+++ ./bin/composer 2022-08-29 07:36:45.053967617 +0200
+--- ./bin/composer.rpm 2023-03-21 15:42:18.000000000 +0100
++++ ./bin/composer 2023-03-21 15:53:50.082632518 +0100
@@ -11,7 +11,7 @@ if (PHP_VERSION_ID < 70205) {
}
@@ -11,8 +11,8 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
use Composer\XdebugHandler\XdebugHandler;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2022-08-29 07:36:45.053967617 +0200
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2022-08-29 07:38:03.936134475 +0200
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2023-03-21 15:42:18.000000000 +0100
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2023-03-21 15:53:50.082632518 +0100
@@ -431,7 +431,7 @@ EOF;
$filesystem->filePutContentsIfModified($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $checkPlatform));
@@ -23,9 +23,9 @@ diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autolo
if ($this->runScripts) {
$this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, [], [
diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
---- ./src/Composer/Compiler.php.rpm 2022-08-29 07:36:37.000000000 +0200
-+++ ./src/Composer/Compiler.php 2022-08-29 07:36:45.053967617 +0200
-@@ -106,7 +106,7 @@ class Compiler
+--- ./src/Composer/Compiler.php.rpm 2023-03-21 15:42:18.000000000 +0100
++++ ./src/Composer/Compiler.php 2023-03-21 15:53:50.082632518 +0100
+@@ -105,7 +105,7 @@ class Compiler
// Add Composer resources
$finder = new Finder();
$finder->files()
@@ -35,8 +35,8 @@ diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
;
foreach ($finder as $file) {
diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersions.php
---- ./src/Composer/InstalledVersions.php.rpm 2022-08-29 07:36:37.000000000 +0200
-+++ ./src/Composer/InstalledVersions.php 2022-08-29 07:36:45.053967617 +0200
+--- ./src/Composer/InstalledVersions.php.rpm 2023-03-21 15:42:18.000000000 +0100
++++ ./src/Composer/InstalledVersions.php 2023-03-21 15:55:07.748460545 +0100
@@ -266,7 +266,7 @@ class InstalledVersions
if (null === self::$installed) {
// only require the installed.php file if this file is loaded from its dumped location,
@@ -46,19 +46,19 @@ diff -up ./src/Composer/InstalledVersions.php.rpm ./src/Composer/InstalledVersio
self::$installed = include __DIR__ . '/installed.php';
} else {
self::$installed = array();
-@@ -339,7 +339,7 @@ class InstalledVersions
+@@ -341,7 +341,7 @@ class InstalledVersions
if (null === self::$installed) {
// only require the installed.php file if this file is loaded from its dumped location,
// and not from its source location in the composer/composer package, see https://github.com/composer/composer/issues/9937
- if (substr(__DIR__, -8, 1) !== 'C') {
+ if (substr(__DIR__, -8, 1) !== 'C' && is_file(__DIR__ . '/installed.php')) {
- self::$installed = require __DIR__ . '/installed.php';
- } else {
- self::$installed = array();
+ /** @var array{root: array{name: string, pretty_version: string, version: string, reference: string|null, type: string, install_path: string, aliases: string[], dev: bool}, versions: array<string, array{pretty_version?: string, version?: string, reference?: string|null, type?: string, install_path?: string, aliases?: string[], dev_requirement: bool, replaced?: string[], provided?: string[]}>} $required */
+ $required = require __DIR__ . '/installed.php';
+ self::$installed = $required;
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2022-08-29 07:36:37.000000000 +0200
-+++ ./src/Composer/Json/JsonFile.php 2022-08-29 07:36:45.053967617 +0200
-@@ -39,7 +39,7 @@ class JsonFile
+--- ./src/Composer/Json/JsonFile.php.rpm 2023-03-21 15:42:18.000000000 +0100
++++ ./src/Composer/Json/JsonFile.php 2023-03-21 15:53:50.082632518 +0100
+@@ -40,7 +40,7 @@ class JsonFile
/** @deprecated Use \JSON_UNESCAPED_UNICODE */
public const JSON_UNESCAPED_UNICODE = 256;
@@ -67,7 +67,7 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
/** @var string */
private $path;
-@@ -216,7 +216,7 @@ class JsonFile
+@@ -223,7 +223,7 @@ class JsonFile
$isComposerSchemaFile = false;
if (null === $schemaFile) {
$isComposerSchemaFile = true;
@@ -76,21 +76,9 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
}
// Prepend with file:// only when not using a special schema already (e.g. in the phar)
-diff -up ./src/Composer/PHPStan/ConfigReturnTypeExtension.php.rpm ./src/Composer/PHPStan/ConfigReturnTypeExtension.php
---- ./src/Composer/PHPStan/ConfigReturnTypeExtension.php.rpm 2022-08-29 07:36:37.000000000 +0200
-+++ ./src/Composer/PHPStan/ConfigReturnTypeExtension.php 2022-08-29 07:36:45.054967614 +0200
-@@ -39,7 +39,7 @@ final class ConfigReturnTypeExtension im
-
- public function __construct()
- {
-- $schema = JsonFile::parseJson((string) file_get_contents(__DIR__.'/../../../res/composer-schema.json'));
-+ $schema = JsonFile::parseJson((string) file_get_contents('/usr/share/composer/res/composer-schema.json'));
- /**
- * @var string $prop
- */
diff -up ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php
---- ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm 2022-07-20 09:14:26.000000000 +0200
-+++ ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php 2022-08-29 07:36:45.054967614 +0200
+--- ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm 2023-01-11 09:27:00.000000000 +0100
++++ ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php 2023-03-21 15:53:50.083632516 +0100
@@ -125,7 +125,7 @@ class CaBundle
*/
public static function getBundledCaBundlePath()
@@ -100,16 +88,3 @@ diff -up ./src/Composer/vendor/composer/ca-bundle/src/CaBundle.php.rpm ./src/Com
// cURL does not understand 'phar://' paths
// see https://github.com/composer/ca-bundle/issues/10
-diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/Test/Json/ComposerSchemaTest.php
---- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2022-08-29 07:36:45.054967614 +0200
-+++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2022-08-29 07:39:34.814922582 +0200
-@@ -96,7 +96,8 @@ class ComposerSchemaTest extends TestCas
- private function check(string $json)
- {
- $validator = new Validator();
-- $validator->check(json_decode($json), (object) ['$ref' => 'file://' . __DIR__ . '/../../../../res/composer-schema.json']);
-+ $f = (getenv('BUILDROOT')?:'') . '/usr/share/composer/res/composer-schema.json';
-+ $validator->check(json_decode($json), (object) ['$ref' => 'file://' . $f]);
-
- if (!$validator->isValid()) {
- $errors = $validator->getErrors();
diff --git a/composer.spec b/composer.spec
index be9a2b4..2959fa3 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 6b67eeea4d72051c369ccdbfb2423a56e2ab51a9
+%global gh_commit c7cffaad16a60636a776017eac5bd8cd0095c32f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.5.4
+%global upstream_version 2.5.5
#global upstream_prever RC1
#global upstream_lower rc1
@@ -94,10 +94,10 @@ Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.19
+Provides: bundled(php-symfony-console) = v5.4.21
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.19
-Provides: bundled(php-symfony-finder) = v5.4.19
+Provides: bundled(php-symfony-filesystem) = v5.4.21
+Provides: bundled(php-symfony-finder) = v5.4.21
Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
@@ -105,9 +105,9 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
-Provides: bundled(php-symfony-process) = v5.4.19
+Provides: bundled(php-symfony-process) = v5.4.21
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.19
+Provides: bundled(php-symfony-string) = v5.4.21
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 2.5.5-1
+- update to 2.5.5
+
* Wed Feb 15 2023 Remi Collet <remi@remirepo.net> - 2.5.4-1
- update to 2.5.4
diff --git a/installed.json b/installed.json
index 56ae93d..30dc88f 100644
--- a/installed.json
+++ b/installed.json
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740"
+ "reference": "c77433ddc6cdc689caf48065d9ea22ca0853fbd9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/dccb8d251a9017d5994c988b034d3e18aaabf740",
- "reference": "dccb8d251a9017d5994c988b034d3e18aaabf740",
+ "url": "https://api.github.com/repos/symfony/console/zipball/c77433ddc6cdc689caf48065d9ea22ca0853fbd9",
+ "reference": "c77433ddc6cdc689caf48065d9ea22ca0853fbd9",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-25T16:59:41+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.19"
+ "source": "https://github.com/symfony/console/tree/v5.4.21"
},
"funding": [
{
@@ -1149,17 +1149,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8"
+ "reference": "e75960b1bbfd2b8c9e483e0d74811d555ca3de9f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/648bfaca6a494f3e22378123bcee2894045dc9d8",
- "reference": "648bfaca6a494f3e22378123bcee2894045dc9d8",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/e75960b1bbfd2b8c9e483e0d74811d555ca3de9f",
+ "reference": "e75960b1bbfd2b8c9e483e0d74811d555ca3de9f",
"shasum": ""
},
"require": {
@@ -1168,7 +1168,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-14T19:14:44+00:00",
+ "time": "2023-02-14T08:03:56+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1196,7 +1196,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.19"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.21"
},
"funding": [
{
@@ -1216,17 +1216,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f"
+ "reference": "078e9a5e1871fcfe6a5ce421b539344c21afef19"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/6071aebf810ad13fe8200c224f36103abb37cf1f",
- "reference": "6071aebf810ad13fe8200c224f36103abb37cf1f",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/078e9a5e1871fcfe6a5ce421b539344c21afef19",
+ "reference": "078e9a5e1871fcfe6a5ce421b539344c21afef19",
"shasum": ""
},
"require": {
@@ -1234,7 +1234,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-14T19:14:44+00:00",
+ "time": "2023-02-16T09:33:00+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1262,7 +1262,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.19"
+ "source": "https://github.com/symfony/finder/tree/v5.4.21"
},
"funding": [
{
@@ -1874,24 +1874,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1"
+ "reference": "d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
- "reference": "c5ba874c9b636dbccf761e22ce750e88ec3f55e1",
+ "url": "https://api.github.com/repos/symfony/process/zipball/d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd",
+ "reference": "d4ce417ebcb0b7d090b4c178ed6d3accc518e8bd",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-21T19:46:44+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1919,7 +1919,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.19"
+ "source": "https://github.com/symfony/process/tree/v5.4.21"
},
"funding": [
{
@@ -2025,17 +2025,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.19",
- "version_normalized": "5.4.19.0",
+ "version": "v5.4.21",
+ "version_normalized": "5.4.21.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb"
+ "reference": "edac10d167b78b1d90f46a80320d632de0bd9f2f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/0a01071610fd861cc160dfb7e2682ceec66064cb",
- "reference": "0a01071610fd861cc160dfb7e2682ceec66064cb",
+ "url": "https://api.github.com/repos/symfony/string/zipball/edac10d167b78b1d90f46a80320d632de0bd9f2f",
+ "reference": "edac10d167b78b1d90f46a80320d632de0bd9f2f",
"shasum": ""
},
"require": {
@@ -2055,7 +2055,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2023-01-01T08:32:19+00:00",
+ "time": "2023-02-22T08:00:55+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2094,7 +2094,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.19"
+ "source": "https://github.com/symfony/string/tree/v5.4.21"
},
"funding": [
{