summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--composer.json3
-rw-r--r--composer.spec22
3 files changed, 20 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index 97b271d..e588cb7 100644
--- a/composer.json
+++ b/composer.json
@@ -37,7 +37,8 @@
"symfony/process": "^2.7 || ^3.0 || ^4.0 || ^5.0"
},
"conflict": {
- "symfony/console": "2.8.38"
+ "symfony/console": "2.8.38",
+ "symfony/phpunit-bridge": "3.4.40"
},
"require-dev": {
"symfony/phpunit-bridge": "^3.4",
diff --git a/composer.spec b/composer.spec
index 9e134dd..4f8bb64 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,15 +10,16 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7a4d5b6aa30d2118af27c04f5e897b57156ccfa9
+%global gh_commit be81b9c4735362c26876bdbfd3b5bc7e7f711c88
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global api_version 1.1.0
+%global run_version 1.0.0
-%global upstream_version 1.10.5
+%global upstream_version 1.10.6
#global upstream_prever RC
%if 0
@@ -170,6 +171,7 @@ Requires: php-zlib
Provides: php-composer(composer/composer) = %{version}
# Special internal for Plugin API
Provides: php-composer(composer-plugin-api) = %{api_version}
+Provides: php-composer(composer-runtime-api) = %{run_version}
%description
@@ -209,10 +211,14 @@ sed -e '/BRANCH_ALIAS_VERSION/s/@package_branch_alias_version@//' \
: check Plugin API version
php -r '
-namespace Composer\Plugin;
-include "src/Composer/Plugin/PluginInterface.php";
-if (version_compare(PluginInterface::PLUGIN_API_VERSION, "%{api_version}")) {
- printf("Plugin API version is %s, expected %s\n", PluginInterface::PLUGIN_API_VERSION, "%{api_version}");
+namespace Composer;
+include "src/Composer/autoload.php";
+if (version_compare(Plugin\PluginInterface::PLUGIN_API_VERSION, "%{api_version}")) {
+ printf("Plugin API version is %s, expected %s\n", Plugin\PluginInterface::PLUGIN_API_VERSION, "%{api_version}");
+ exit(1);
+}
+if (version_compare(Composer::RUNTIME_API_VERSION, "%{run_version}")) {
+ printf("Plugin API version is %s, expected %s\n", Composer::RUNTIME_API_VERSION, "%{run_version}");
exit(1);
}'
@@ -283,6 +289,10 @@ exit $ret
%changelog
+* Wed May 6 2020 Remi Collet <remi@remirepo.net> - 1.10.6-1
+- update to 1.10.6
+- provide php-composer(composer-runtime-api)
+
* Fri Apr 10 2020 Remi Collet <remi@remirepo.net> - 1.10.5-1
- update to 1.10.5