summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-rpm.patch26
-rw-r--r--composer.json3
-rw-r--r--composer.spec11
3 files changed, 23 insertions, 17 deletions
diff --git a/composer-rpm.patch b/composer-rpm.patch
index 9b896a2..44eb5b1 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,18 +1,18 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2017-03-08 17:51:24.000000000 +0100
-+++ ./bin/composer 2017-03-08 19:16:24.206124958 +0100
-@@ -5,7 +5,7 @@ if (PHP_SAPI !== 'cli') {
- echo 'Warning: Composer should be invoked via the CLI version of PHP, not the '.PHP_SAPI.' SAPI'.PHP_EOL;
+--- ./bin/composer.rpm 2018-05-04 12:59:13.065292434 +0200
++++ ./bin/composer 2018-05-04 13:00:23.293493373 +0200
+@@ -6,7 +6,7 @@ if (PHP_SAPI !== 'cli') {
}
+ setlocale(LC_ALL, 'C');
-require __DIR__.'/../src/bootstrap.php';
+require '/usr/share/php/Composer/autoload.php';
use Composer\Factory;
use Composer\XdebugHandler;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2017-03-08 17:51:24.000000000 +0100
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2017-03-08 19:16:24.207124963 +0100
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2018-05-04 12:57:41.000000000 +0200
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2018-05-04 12:59:13.066292451 +0200
@@ -305,7 +305,7 @@ EOF;
file_put_contents($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $staticPhpVersion));
@@ -23,8 +23,8 @@ diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autolo
if ($this->runScripts) {
$this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
---- ./src/Composer/Compiler.php.rpm 2017-03-08 17:51:24.000000000 +0100
-+++ ./src/Composer/Compiler.php 2017-03-08 19:16:24.207124963 +0100
+--- ./src/Composer/Compiler.php.rpm 2018-05-04 12:57:41.000000000 +0200
++++ ./src/Composer/Compiler.php 2018-05-04 12:59:13.066292451 +0200
@@ -97,7 +97,7 @@ class Compiler
$finder = new Finder();
$finder->files()
@@ -35,8 +35,8 @@ diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
->sort($finderSort)
;
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2017-03-08 19:16:24.207124963 +0100
-+++ ./src/Composer/Json/JsonFile.php 2017-03-08 19:17:35.148449586 +0100
+--- ./src/Composer/Json/JsonFile.php.rpm 2018-05-04 12:57:41.000000000 +0200
++++ ./src/Composer/Json/JsonFile.php 2018-05-04 12:59:13.066292451 +0200
@@ -156,7 +156,7 @@ class JsonFile
self::validateSyntax($content, $this->path);
}
@@ -47,9 +47,9 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
// Prepend with file:// only when not using a special schema already (e.g. in the phar)
if (false === strpos($schemaFile, '://')) {
diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/Test/Json/ComposerSchemaTest.php
---- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2017-03-08 19:16:24.207124963 +0100
-+++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2017-03-08 19:19:02.243848127 +0100
-@@ -96,7 +96,8 @@ class ComposerSchemaTest extends \PHPUni
+--- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2018-05-04 12:57:41.000000000 +0200
++++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2018-05-04 12:59:13.066292451 +0200
+@@ -97,7 +97,8 @@ class ComposerSchemaTest extends TestCas
private function check($json)
{
$validator = new Validator();
diff --git a/composer.json b/composer.json
index 74030a4..338a8b2 100644
--- a/composer.json
+++ b/composer.json
@@ -40,6 +40,9 @@
"phpunit/phpunit": "^4.8.35 || ^5.7",
"phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
},
+ "conflict": {
+ "symfony/console": "2.8.38"
+ },
"config": {
"platform": {
"php": "5.3.9"
diff --git a/composer.spec b/composer.spec
index 83f088e..5c1611f 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 86ad51e8a3c64c9782446aae740a61fc6faa2522
+%global gh_commit b184a92419cc9a9c4c6a09db555a94d441cb11c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global api_version 1.1.0
-%global upstream_version 1.6.4
+%global upstream_version 1.6.5
#global upstream_prever RC
%if 0
@@ -52,7 +52,7 @@ BuildArch: noarch
BuildRequires: php-cli
%if %{with_tests}
BuildRequires: php-justinrainbow-json-schema5
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2)
BuildRequires: (php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2)
BuildRequires: (php-composer(composer/semver) >= 1.0 with php-composer(composer/semver) < 2)
@@ -109,7 +109,7 @@ BuildRequires: php-PsrLog >= 1.0.0-8
Requires: php(language) >= 5.3.2
Requires: php-cli
Requires: php-justinrainbow-json-schema5
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2)
Requires: (php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2)
Requires: (php-composer(composer/semver) >= 1.0 with php-composer(composer/semver) < 2)
@@ -289,6 +289,9 @@ exit $ret
%changelog
+* Fri May 4 2018 Remi Collet <remi@remirepo.net> - 1.6.5-1
+- update to 1.6.5
+
* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 1.6.4-1
- update to 1.6.4