summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json67
-rw-r--r--composer.spec7
2 files changed, 72 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f457758
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,67 @@
+{
+ "name": "composer/composer",
+ "description": "Composer helps you declare, manage and install dependencies of PHP projects, ensuring you have the right stack everywhere.",
+ "keywords": ["package", "dependency", "autoload"],
+ "homepage": "https://getcomposer.org/",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Nils Adermann",
+ "email": "naderman@naderman.de",
+ "homepage": "http://www.naderman.de"
+ },
+ {
+ "name": "Jordi Boggiano",
+ "email": "j.boggiano@seld.be",
+ "homepage": "http://seld.be"
+ }
+ ],
+ "support": {
+ "irc": "irc://irc.freenode.org/composer",
+ "issues": "https://github.com/composer/composer/issues"
+ },
+ "require": {
+ "php": "^5.3.2 || ^7.0",
+ "justinrainbow/json-schema": "^1.6",
+ "composer/spdx-licenses": "^1.0",
+ "composer/semver": "^1.0",
+ "seld/jsonlint": "^1.4",
+ "symfony/console": "^2.5 || ^3.0",
+ "symfony/finder": "^2.2 || ^3.0",
+ "symfony/process": "^2.1 || ^3.0",
+ "symfony/filesystem": "^2.5 || ^3.0",
+ "seld/phar-utils": "^1.0",
+ "seld/cli-prompt": "^1.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.5 || ^5.0.5",
+ "phpunit/phpunit-mock-objects": "2.3.0 || ^3.0"
+ },
+ "_": "phpunit/phpunit-mock-objects required in 2.3.0 due to https://github.com/sebastianbergmann/phpunit-mock-objects/issues/223 - needs hhvm 3.8+ on travis",
+ "config": {
+ "platform": {
+ "php": "5.3.9"
+ }
+ },
+ "suggest": {
+ "ext-zip": "Enabling the zip extension allows you to unzip archives",
+ "ext-zlib": "Allow gzip compression of HTTP requests",
+ "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages"
+ },
+ "autoload": {
+ "psr-4": { "Composer\\": "src/Composer" }
+ },
+ "autoload-dev": {
+ "psr-4": { "Composer\\Test\\": "tests/Composer/Test" }
+ },
+ "bin": ["bin/composer"],
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0-dev"
+ }
+ },
+ "scripts": {
+ "test": "phpunit"
+ }
+}
diff --git a/composer.spec b/composer.spec
index dae59a7..67f728f 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 32df3aa8cdbdaa16df9491b5e672e81c87f94c78
+%global gh_commit de0e25b0d494ace6b571a9205b82d017e5cb9257
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
@@ -15,7 +15,7 @@
%global api_version 1.0.0
Name: composer
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}
Summary: Dependency Manager for PHP
@@ -219,6 +219,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Apr 19 2016 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- update to 1.0.1
+
* Tue Apr 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- update to 1.0.0