summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--550c01b471c0deecf95647b7b48e7712623208da.patch27
-rw-r--r--composer.spec11
2 files changed, 6 insertions, 32 deletions
diff --git a/550c01b471c0deecf95647b7b48e7712623208da.patch b/550c01b471c0deecf95647b7b48e7712623208da.patch
deleted file mode 100644
index f5dd971..0000000
--- a/550c01b471c0deecf95647b7b48e7712623208da.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 550c01b471c0deecf95647b7b48e7712623208da Mon Sep 17 00:00:00 2001
-From: rbairwell <rbairwell@users.noreply.github.com>
-Date: Tue, 27 Aug 2019 20:53:57 +0100
-Subject: [PATCH] Fixes a problem with path based repositories on PHP7.4 where
- an attempt is made to access null as an array
-
----
- src/Composer/Repository/PathRepository.php | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/Composer/Repository/PathRepository.php b/src/Composer/Repository/PathRepository.php
-index 61ebc8d8cd3c..20dcbcd6faa0 100644
---- a/src/Composer/Repository/PathRepository.php
-+++ b/src/Composer/Repository/PathRepository.php
-@@ -155,7 +155,11 @@ protected function initialize()
-
- if (!isset($package['version'])) {
- $versionData = $this->versionGuesser->guessVersion($package, $path);
-- $package['version'] = $versionData['pretty_version'] ?: 'dev-master';
-+ if (is_array($versionData)) {
-+ $package['version'] = $versionData['pretty_version'] ?: 'dev-master';
-+ } else {
-+ $package['version'] = 'dev-master';
-+ }
- }
-
- $output = '';
diff --git a/composer.spec b/composer.spec
index 33d9faf..e73fd80 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 314aa57fdcfc942065996f59fb73a8b3f74f3fa5
+%global gh_commit bb01f2180df87ce7992b8331a68904f80439dd2f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global api_version 1.1.0
-%global upstream_version 1.9.0
+%global upstream_version 1.9.1
#global upstream_prever RC
%if 0
@@ -30,7 +30,7 @@
Name: composer
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Dependency Manager for PHP
License: MIT
@@ -46,7 +46,6 @@ Source5: makesrc.sh
# Use our autoloader, resources path, fix for tests
Patch0: %{name}-rpm.patch
-Patch1: https://github.com/composer/composer/commit/550c01b471c0deecf95647b7b48e7712623208da.patch
BuildArch: noarch
BuildRequires: php-cli
@@ -185,7 +184,6 @@ Documentation: https://getcomposer.org/doc/
%patch0 -p1 -b .rpm
find . -name \*.rpm -exec rm {} \; -print
-%patch1 -p1
if grep -r '\.\./res'; then
: Patch need to fixed
@@ -285,6 +283,9 @@ exit $ret
%changelog
+* Sat Nov 2 2019 Remi Collet <remi@remirepo.net> - 1.9.1-1
+- update to 1.9.1
+
* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 1.9.0-2
- add upstream patch for PHP 7.4