summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json12
-rw-r--r--composer.spec32
-rwxr-xr-xmakesrc.sh28
3 files changed, 54 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 346af21..30d9f91 100644
--- a/composer.json
+++ b/composer.json
@@ -28,16 +28,16 @@
"composer/semver": "^1.0",
"composer/spdx-licenses": "^1.0",
"seld/jsonlint": "^1.4",
- "symfony/console": "^2.7 || ^3.0",
- "symfony/finder": "^2.7 || ^3.0",
- "symfony/process": "^2.7 || ^3.0",
- "symfony/filesystem": "^2.7 || ^3.0",
+ "symfony/console": "^2.7 || ^3.0 || ^4.0",
+ "symfony/finder": "^2.7 || ^3.0 || ^4.0",
+ "symfony/process": "^2.7 || ^3.0 || ^4.0",
+ "symfony/filesystem": "^2.7 || ^3.0 || ^4.0",
"seld/phar-utils": "^1.0",
"seld/cli-prompt": "^1.0",
"psr/log": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.5 || ^5.0.5",
+ "phpunit/phpunit": "^4.8.35 || ^5.7",
"phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
},
"config": {
@@ -59,7 +59,7 @@
"bin": ["bin/composer"],
"extra": {
"branch-alias": {
- "dev-master": "1.5-dev"
+ "dev-master": "1.6-dev"
}
},
"scripts": {
diff --git a/composer.spec b/composer.spec
index d201a74..a3f8bb4 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,35 +6,39 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 4f7f9c12753ec43f1e4629e2a71cabe81f2a4eab
+%global gh_commit f76c7a4b91694960c7b6784d639fee11b38e671b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
%global api_version 1.1.0
-#global prever RC
+
+%global upstream_version 1.6.0
+%global upstream_prever RC
%if 0%{?fedora} >= 27
-%global symfony_prefix php-symfony3
+%global symfony_prefix php-symfony4
%else
%global symfony_prefix php-symfony
%endif
Name: composer
-Version: 1.5.6
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}
Summary: Dependency Manager for PHP
Group: Development/Libraries
License: MIT
URL: https://getcomposer.org/
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
+Source0: %{gh_project}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tgz
Source1: %{name}-autoload.php
Source2: %{name}-bootstrap.php
# Profile scripts
Source3: %{name}.sh
Source4: %{name}.csh
+# Get a git snapshot to retrieve the test suite
+Source5: makesrc.sh
# Use our autoloader, resources path, fix for tests
Patch0: %{name}-rpm.patch
@@ -63,9 +67,9 @@ BuildRequires: %{symfony_prefix}-filesystem
BuildRequires: %{symfony_prefix}-process
BuildRequires: php-zip
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^4.5 || ^5.0.5",
+# "phpunit/phpunit": "^4.8.35 || ^5.7",
# "phpunit/phpunit-mock-objects": "^2.3 || ^3.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.5
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
# For autoloader
BuildRequires: php-composer(fedora/autoloader) >= 0.1.2
BuildRequires: php-seld-phar-utils >= 1.0.1
@@ -80,10 +84,10 @@ BuildRequires: php-PsrLog >= 1.0.0-8
# "composer/semver": "^1.0",
# "composer/spdx-licenses": "^1.0",
# "seld/jsonlint": "~1.4",
-# "symfony/console": "^2.7 || ^3.0",
-# "symfony/finder": "^2.7 || ^3.0",
-# "symfony/process": "^2.7 || ^3.0",
-# "symfony/filesystem": "^2.7 || ^3.0",
+# "symfony/console": "^2.7 || ^3.0 || ^4.0",
+# "symfony/finder": "^2.7 || ^3.0 || ^4.0",
+# "symfony/process": "^2.7 || ^3.0 || ^4.0",
+# "symfony/filesystem": "^2.7 || ^3.0 || ^4.0",
# "seld/phar-utils": "^1.0",
# "seld/cli-prompt": "^1.0",
# "psr/log": "^1.0"
@@ -235,7 +239,7 @@ export BUILDROOT=%{buildroot}
# testIntegration may hang on local build
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit \
--filter '^((?!(testIntegration)).)*$' \
@@ -260,6 +264,10 @@ exit $ret
%changelog
+* Wed Dec 20 2017 Remi Collet <remi@remirepo.net> - 1.6.0~RC-1
+- update to 1.6.0-RC
+- switch to Symfony 4 on F27+
+
* Mon Dec 18 2017 Remi Collet <remi@remirepo.net> - 1.5.6-1
- Update to 1.5.6
- switch to symfony package names
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..9615a91
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(sed -n '/^Name:/{s/.* //;p}' *.spec)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^%global upstream_version/{s/.* //;p}' $NAME.spec)
+PREVER=$(sed -n '/^%global upstream_prever/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION$PREVER\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION$PREVER-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."