summaryrefslogtreecommitdiffstats
path: root/composer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-31 09:15:13 +0100
committerRemi Collet <remi@php.net>2022-01-31 09:15:13 +0100
commitca3bfb0423888a348d98680b2d5fa4131473e00f (patch)
tree666f8e0ea8a8d4d9d3cfcc57cdb41ea11e8c2c17 /composer.spec
parent04a24238b93342faf0767ecb3f7f2f74cfe69317 (diff)
lower minimal php version back to 7.2.5
Diffstat (limited to 'composer.spec')
-rw-r--r--composer.spec21
1 files changed, 12 insertions, 9 deletions
diff --git a/composer.spec b/composer.spec
index 6fd5675..70c4270 100644
--- a/composer.spec
+++ b/composer.spec
@@ -38,7 +38,7 @@
Name: composer
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Dependency Manager for PHP
# composer and all dependencies are MIT
@@ -58,7 +58,7 @@ Patch1: %{name}-noxdg.patch
BuildArch: noarch
# platform set in makesrc.sh
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 7.2.5
BuildRequires: php-cli
BuildRequires: php-json
%if %{with tests}
@@ -119,7 +119,7 @@ BuildRequires: php-fedora-autoloader-devel
# "symfony/process": "^^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
# "react/promise": "^1.2 || ^2.7",
# "composer/pcre": "^1.0"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 7.2.5
Requires: php-cli
%if %{with syslib}
# remirepo:1
@@ -166,24 +166,24 @@ Provides: bundled(php-composer-semver) = 3.2.7
Provides: bundled(php-composer-spdx-licenses) = 1.5.6
Provides: bundled(php-composer-xdebug-handler) = 2.0.4
Provides: bundled(php-justinrainbow-json-schema) = 5.2.11
-Provides: bundled(php-psr-container) = 1.1.2
+Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.8.0
Provides: bundled(php-seld-jsonlint) = 1.8.3
Provides: bundled(php-seld-phar-utils) = 1.2.0
-Provides: bundled(php-symfony-console) = v5.4.2
+Provides: bundled(php-symfony-console) = v5.4.3
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
-Provides: bundled(php-symfony-filesystem) = v5.4.0
-Provides: bundled(php-symfony-finder) = v5.4.2
+Provides: bundled(php-symfony-filesystem) = v5.4.3
+Provides: bundled(php-symfony-finder) = v5.4.3
Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.24.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.24.0
Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
-Provides: bundled(php-symfony-process) = v5.4.2
+Provides: bundled(php-symfony-process) = v5.4.3
Provides: bundled(php-symfony-service-contracts) = v2.5.0
-Provides: bundled(php-symfony-string) = v5.4.2
+Provides: bundled(php-symfony-string) = v5.4.3
%endif
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -402,6 +402,9 @@ exit $ret
%changelog
+* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 2.2.5-3
+- lower minimal php version back to 7.2.5
+
* Tue Jan 25 2022 Remi Collet <remi@remirepo.net> - 2.2.5-2
- use system libraries on Fedora, bundled libraries on EL