summaryrefslogtreecommitdiffstats
path: root/composer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-31 08:18:02 +0100
committerRemi Collet <remi@remirepo.net>2020-10-31 08:18:02 +0100
commit2a5391fb59d622eee50147186f0129a584189483 (patch)
tree80eb6ba3d37ce85f6f1b6a03797837a68176ec3a /composer.spec
parent937e40bce7bcc09c87f4670db61079dc536d4450 (diff)
update to 2.0.4
Diffstat (limited to 'composer.spec')
-rw-r--r--composer.spec15
1 files changed, 12 insertions, 3 deletions
diff --git a/composer.spec b/composer.spec
index f1f0043..12a2af6 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit f7eebdd092873f5d63929f21183e69ec9f5e83cd
+%global gh_commit 4053eab90a7cdf0b81dd93073dc6c18c15d487fd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -19,7 +19,7 @@
%global api_version 2.0.0
%global run_version 2.0.0
-%global upstream_version 2.0.3
+%global upstream_version 2.0.4
#global upstream_prever RC2
#global upstream_lower rc2
@@ -285,12 +285,18 @@ rm -rf res
: Run test suite
export BUILDROOT=%{buildroot}
+%if 0%{?rhel} == 6
+FILTER="--filter '^((?!(testIntegration|testArchiveCustomFileName|testArchiveTar)).)*$'"
+%else
+FILTER="--filter '^((?!(testIntegration)).)*$'"
+%endif
+
# testIntegration may hang on local build
ret=0
for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd -d memory_limit=1G %{_phpunit} \
- --filter '^((?!(testIntegration)).)*$' \
+ $FILTER \
--include-path %{buildroot}%{_datadir}/php || ret=1
fi
done
@@ -312,6 +318,9 @@ exit $ret
%changelog
+* Sat Oct 31 2020 Remi Collet <remi@remirepo.net> - 2.0.4-1
+- update to 2.0.4
+
* Thu Oct 29 2020 Remi Collet <remi@remirepo.net> - 2.0.3-1
- update to 2.0.3