summaryrefslogtreecommitdiffstats
path: root/composer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-20 13:45:31 +0100
committerRemi Collet <remi@php.net>2022-12-20 13:45:31 +0100
commit09ade9d89a9f0e1c917683f8ed8590be46793470 (patch)
tree45c4c1fe822aa9bb5b19caa71c722f96475a31e3 /composer.spec
parentab250273e212c69343f3a4199b3b8c44be40d24b (diff)
update to 2.5.0
Diffstat (limited to 'composer.spec')
-rw-r--r--composer.spec28
1 files changed, 16 insertions, 12 deletions
diff --git a/composer.spec b/composer.spec
index 049e5a7..dce242c 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e8d9087229bcdbc5867594d3098091412f1130cf
+%global gh_commit 09ef0e3acbb377f28927fa6a527c251da713ebac
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.4.4
+%global upstream_version 2.5.0
#global upstream_prever RC1
#global upstream_lower rc1
@@ -32,7 +32,7 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 1%{?dist}
Summary: Dependency Manager for PHP
-# composer and all dependencies are MIT
+# SPDX: composer and all dependencies are MIT
License: MIT
URL: https://getcomposer.org/
Source0: %{gh_project}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tgz
@@ -83,7 +83,7 @@ Requires: ca-certificates
Provides: bundled(php-composer-ca-bundle) = 1.3.4
Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.0.0
+Provides: bundled(php-composer-pcre) = 2.1.0
Provides: bundled(php-composer-semver) = 3.3.2
Provides: bundled(php-composer-spdx-licenses) = 1.5.7
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
@@ -94,19 +94,20 @@ Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.14
+Provides: bundled(php-symfony-console) = v5.4.16
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.13
Provides: bundled(php-symfony-finder) = v5.4.11
-Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.26.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.26.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
+Provides: bundled(php-symfony-polyfill-ctype) = v1.27.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.27.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.27.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.27.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.27.0
Provides: bundled(php-symfony-process) = v5.4.11
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.14
+Provides: bundled(php-symfony-string) = v5.4.15
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -248,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+
* Fri Oct 28 2022 Remi Collet <remi@remirepo.net> - 2.4.4-1
- update to 2.4.4