summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-31 09:15:13 +0100
committerRemi Collet <remi@php.net>2022-01-31 09:15:13 +0100
commitca3bfb0423888a348d98680b2d5fa4131473e00f (patch)
tree666f8e0ea8a8d4d9d3cfcc57cdb41ea11e8c2c17
parent04a24238b93342faf0767ecb3f7f2f74cfe69317 (diff)
lower minimal php version back to 7.2.5
-rw-r--r--composer.spec21
-rw-r--r--installed.json86
-rwxr-xr-xmakesrc.sh2
3 files changed, 56 insertions, 53 deletions
diff --git a/composer.spec b/composer.spec
index 6fd5675..70c4270 100644
--- a/composer.spec
+++ b/composer.spec
@@ -38,7 +38,7 @@
Name: composer
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Dependency Manager for PHP
# composer and all dependencies are MIT
@@ -58,7 +58,7 @@ Patch1: %{name}-noxdg.patch
BuildArch: noarch
# platform set in makesrc.sh
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 7.2.5
BuildRequires: php-cli
BuildRequires: php-json
%if %{with tests}
@@ -119,7 +119,7 @@ BuildRequires: php-fedora-autoloader-devel
# "symfony/process": "^^2.8.52 || ^3.4.35 || ^4.4 || ^5.0 || ^6.0",
# "react/promise": "^1.2 || ^2.7",
# "composer/pcre": "^1.0"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 7.2.5
Requires: php-cli
%if %{with syslib}
# remirepo:1
@@ -166,24 +166,24 @@ Provides: bundled(php-composer-semver) = 3.2.7
Provides: bundled(php-composer-spdx-licenses) = 1.5.6
Provides: bundled(php-composer-xdebug-handler) = 2.0.4
Provides: bundled(php-justinrainbow-json-schema) = 5.2.11
-Provides: bundled(php-psr-container) = 1.1.2
+Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.8.0
Provides: bundled(php-seld-jsonlint) = 1.8.3
Provides: bundled(php-seld-phar-utils) = 1.2.0
-Provides: bundled(php-symfony-console) = v5.4.2
+Provides: bundled(php-symfony-console) = v5.4.3
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.0
-Provides: bundled(php-symfony-filesystem) = v5.4.0
-Provides: bundled(php-symfony-finder) = v5.4.2
+Provides: bundled(php-symfony-filesystem) = v5.4.3
+Provides: bundled(php-symfony-finder) = v5.4.3
Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.24.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.24.0
Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
-Provides: bundled(php-symfony-process) = v5.4.2
+Provides: bundled(php-symfony-process) = v5.4.3
Provides: bundled(php-symfony-service-contracts) = v2.5.0
-Provides: bundled(php-symfony-string) = v5.4.2
+Provides: bundled(php-symfony-string) = v5.4.3
%endif
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -402,6 +402,9 @@ exit $ret
%changelog
+* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 2.2.5-3
+- lower minimal php version back to 7.2.5
+
* Tue Jan 25 2022 Remi Collet <remi@remirepo.net> - 2.2.5-2
- use system libraries on Fedora, bundled libraries on EL
diff --git a/installed.json b/installed.json
index 32f6fd9..3f714cd 100644
--- a/installed.json
+++ b/installed.json
@@ -536,23 +536,23 @@
},
{
"name": "psr/container",
- "version": "1.1.2",
- "version_normalized": "1.1.2.0",
+ "version": "1.1.1",
+ "version_normalized": "1.1.1.0",
"source": {
"type": "git",
"url": "https://github.com/php-fig/container.git",
- "reference": "513e0666f7216c7459170d56df27dfcefe1689ea"
+ "reference": "8622567409010282b7aeebe4bb841fe98b58dcaf"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/php-fig/container/zipball/513e0666f7216c7459170d56df27dfcefe1689ea",
- "reference": "513e0666f7216c7459170d56df27dfcefe1689ea",
+ "url": "https://api.github.com/repos/php-fig/container/zipball/8622567409010282b7aeebe4bb841fe98b58dcaf",
+ "reference": "8622567409010282b7aeebe4bb841fe98b58dcaf",
"shasum": ""
},
"require": {
- "php": ">=7.4.0"
+ "php": ">=7.2.0"
},
- "time": "2021-11-05T16:50:12+00:00",
+ "time": "2021-03-05T17:36:06+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -581,7 +581,7 @@
],
"support": {
"issues": "https://github.com/php-fig/container/issues",
- "source": "https://github.com/php-fig/container/tree/1.1.2"
+ "source": "https://github.com/php-fig/container/tree/1.1.1"
},
"install-path": "../psr/container"
},
@@ -810,17 +810,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.2",
- "version_normalized": "5.4.2.0",
+ "version": "v5.4.3",
+ "version_normalized": "5.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "a2c6b7ced2eb7799a35375fb9022519282b5405e"
+ "reference": "a2a86ec353d825c75856c6fd14fac416a7bdb6b8"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/a2c6b7ced2eb7799a35375fb9022519282b5405e",
- "reference": "a2c6b7ced2eb7799a35375fb9022519282b5405e",
+ "url": "https://api.github.com/repos/symfony/console/zipball/a2a86ec353d825c75856c6fd14fac416a7bdb6b8",
+ "reference": "a2a86ec353d825c75856c6fd14fac416a7bdb6b8",
"shasum": ""
},
"require": {
@@ -858,7 +858,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2021-12-20T16:11:12+00:00",
+ "time": "2022-01-26T16:28:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -892,7 +892,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.2"
+ "source": "https://github.com/symfony/console/tree/v5.4.3"
},
"funding": [
{
@@ -982,17 +982,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.0",
- "version_normalized": "5.4.0.0",
+ "version": "v5.4.3",
+ "version_normalized": "5.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "731f917dc31edcffec2c6a777f3698c33bea8f01"
+ "reference": "0f0c4bf1840420f4aef3f32044a9dbb24682731b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/731f917dc31edcffec2c6a777f3698c33bea8f01",
- "reference": "731f917dc31edcffec2c6a777f3698c33bea8f01",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/0f0c4bf1840420f4aef3f32044a9dbb24682731b",
+ "reference": "0f0c4bf1840420f4aef3f32044a9dbb24682731b",
"shasum": ""
},
"require": {
@@ -1001,7 +1001,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2021-10-28T13:39:27+00:00",
+ "time": "2022-01-02T09:53:40+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1029,7 +1029,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.0"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.3"
},
"funding": [
{
@@ -1049,17 +1049,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.2",
- "version_normalized": "5.4.2.0",
+ "version": "v5.4.3",
+ "version_normalized": "5.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "e77046c252be48c48a40816187ed527703c8f76c"
+ "reference": "231313534dded84c7ecaa79d14bc5da4ccb69b7d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/e77046c252be48c48a40816187ed527703c8f76c",
- "reference": "e77046c252be48c48a40816187ed527703c8f76c",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/231313534dded84c7ecaa79d14bc5da4ccb69b7d",
+ "reference": "231313534dded84c7ecaa79d14bc5da4ccb69b7d",
"shasum": ""
},
"require": {
@@ -1067,7 +1067,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2021-12-15T11:06:13+00:00",
+ "time": "2022-01-26T16:34:36+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1095,7 +1095,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.2"
+ "source": "https://github.com/symfony/finder/tree/v5.4.3"
},
"funding": [
{
@@ -1625,24 +1625,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.2",
- "version_normalized": "5.4.2.0",
+ "version": "v5.4.3",
+ "version_normalized": "5.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "2b3ba8722c4aaf3e88011be5e7f48710088fb5e4"
+ "reference": "553f50487389a977eb31cf6b37faae56da00f753"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/2b3ba8722c4aaf3e88011be5e7f48710088fb5e4",
- "reference": "2b3ba8722c4aaf3e88011be5e7f48710088fb5e4",
+ "url": "https://api.github.com/repos/symfony/process/zipball/553f50487389a977eb31cf6b37faae56da00f753",
+ "reference": "553f50487389a977eb31cf6b37faae56da00f753",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2021-12-27T21:01:00+00:00",
+ "time": "2022-01-26T16:28:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1670,7 +1670,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.2"
+ "source": "https://github.com/symfony/process/tree/v5.4.3"
},
"funding": [
{
@@ -1776,17 +1776,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.2",
- "version_normalized": "5.4.2.0",
+ "version": "v5.4.3",
+ "version_normalized": "5.4.3.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "e6a5d5ecf6589c5247d18e0e74e30b11dfd51a3d"
+ "reference": "92043b7d8383e48104e411bc9434b260dbeb5a10"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/e6a5d5ecf6589c5247d18e0e74e30b11dfd51a3d",
- "reference": "e6a5d5ecf6589c5247d18e0e74e30b11dfd51a3d",
+ "url": "https://api.github.com/repos/symfony/string/zipball/92043b7d8383e48104e411bc9434b260dbeb5a10",
+ "reference": "92043b7d8383e48104e411bc9434b260dbeb5a10",
"shasum": ""
},
"require": {
@@ -1806,7 +1806,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2021-12-16T21:52:00+00:00",
+ "time": "2022-01-02T09:53:40+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1845,7 +1845,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.2"
+ "source": "https://github.com/symfony/string/tree/v5.4.3"
},
"funding": [
{
diff --git a/makesrc.sh b/makesrc.sh
index 1d89e2e..930ec0b 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -20,7 +20,7 @@ else
pushd $PROJECT-$COMMIT
git checkout $COMMIT || exit 1
cp composer.json ../composer.json
- composer config platform.php 7.4
+ composer config platform.php 7.2.5
rm composer.lock
export COMPOSER_VENDOR_DIR=src/Composer/vendor
composer install --no-interaction --no-progress --no-dev --optimize-autoloader