summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-04 08:13:52 +0100
committerRemi Collet <remi@remirepo.net>2020-12-04 08:13:52 +0100
commit3732509e721e59f6778fbdb7699bff312300d9b2 (patch)
treeec8086950836a8a3855f89d5fa5fa1ea9ed157d5
parent8538a31835afa86a2b28d8545e9755288370bf43 (diff)
update to 2.0.8
-rw-r--r--composer-rpm.patch36
-rw-r--r--composer.spec7
2 files changed, 24 insertions, 19 deletions
diff --git a/composer-rpm.patch b/composer-rpm.patch
index f027f60..130d62d 100644
--- a/composer-rpm.patch
+++ b/composer-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./bin/composer.rpm ./bin/composer
---- ./bin/composer.rpm 2020-10-25 06:23:06.000000000 +0100
-+++ ./bin/composer 2020-10-25 06:23:12.862707931 +0100
+--- ./bin/composer.rpm 2020-12-04 08:01:03.000000000 +0100
++++ ./bin/composer 2020-12-04 08:07:35.946138601 +0100
@@ -6,7 +6,7 @@ if (PHP_SAPI !== 'cli' && PHP_SAPI !== '
}
@@ -11,9 +11,9 @@ diff -up ./bin/composer.rpm ./bin/composer
use Composer\Console\Application;
use Composer\XdebugHandler\XdebugHandler;
diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autoload/AutoloadGenerator.php
---- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2020-10-25 06:23:06.000000000 +0100
-+++ ./src/Composer/Autoload/AutoloadGenerator.php 2020-10-25 06:23:12.863707931 +0100
-@@ -364,7 +364,7 @@ EOF;
+--- ./src/Composer/Autoload/AutoloadGenerator.php.rpm 2020-12-04 08:01:03.000000000 +0100
++++ ./src/Composer/Autoload/AutoloadGenerator.php 2020-12-04 08:07:35.946138601 +0100
+@@ -373,7 +373,7 @@ EOF;
$filesystem->filePutContentsIfModified($targetDir.'/autoload_real.php', $this->getAutoloadRealFile(true, (bool) $includePathFileContents, $targetDirLoader, (bool) $includeFilesFileContents, $vendorPathCode, $appBaseDirCode, $suffix, $useGlobalIncludePath, $prependAutoloader, $staticPhpVersion, $checkPlatform));
$filesystem->safeCopy(__DIR__.'/ClassLoader.php', $targetDir.'/ClassLoader.php');
@@ -23,9 +23,9 @@ diff -up ./src/Composer/Autoload/AutoloadGenerator.php.rpm ./src/Composer/Autolo
if ($this->runScripts) {
$this->eventDispatcher->dispatchScript(ScriptEvents::POST_AUTOLOAD_DUMP, $this->devMode, array(), array(
diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
---- ./src/Composer/Compiler.php.rpm 2020-10-25 06:23:12.863707931 +0100
-+++ ./src/Composer/Compiler.php 2020-10-25 06:26:14.912591239 +0100
-@@ -99,7 +99,7 @@ class Compiler
+--- ./src/Composer/Compiler.php.rpm 2020-12-04 08:01:03.000000000 +0100
++++ ./src/Composer/Compiler.php 2020-12-04 08:07:35.946138601 +0100
+@@ -98,7 +98,7 @@ class Compiler
// Add Composer resources
$finder = new Finder();
$finder->files()
@@ -35,8 +35,8 @@ diff -up ./src/Composer/Compiler.php.rpm ./src/Composer/Compiler.php
;
foreach ($finder as $file) {
diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
---- ./src/Composer/Json/JsonFile.php.rpm 2020-10-25 06:23:06.000000000 +0100
-+++ ./src/Composer/Json/JsonFile.php 2020-10-25 06:23:12.863707931 +0100
+--- ./src/Composer/Json/JsonFile.php.rpm 2020-12-04 08:01:03.000000000 +0100
++++ ./src/Composer/Json/JsonFile.php 2020-12-04 08:07:35.946138601 +0100
@@ -34,7 +34,7 @@ class JsonFile
const JSON_PRETTY_PRINT = 128;
const JSON_UNESCAPED_UNICODE = 256;
@@ -56,8 +56,8 @@ diff -up ./src/Composer/Json/JsonFile.php.rpm ./src/Composer/Json/JsonFile.php
// Prepend with file:// only when not using a special schema already (e.g. in the phar)
diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/Test/Json/ComposerSchemaTest.php
---- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2020-10-25 06:23:06.000000000 +0100
-+++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2020-10-25 06:23:12.863707931 +0100
+--- ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm 2020-12-04 08:01:03.000000000 +0100
++++ ./tests/Composer/Test/Json/ComposerSchemaTest.php 2020-12-04 08:07:35.947138597 +0100
@@ -113,7 +113,8 @@ class ComposerSchemaTest extends TestCas
private function check($json)
{
@@ -69,15 +69,17 @@ diff -up ./tests/Composer/Test/Json/ComposerSchemaTest.php.rpm ./tests/Composer/
if (!$validator->isValid()) {
$errors = $validator->getErrors();
diff -up ./tests/Composer/Test/PolyfillTestCase.php.rpm ./tests/Composer/Test/PolyfillTestCase.php
---- ./tests/Composer/Test/PolyfillTestCase.php.rpm 2020-10-25 06:23:06.000000000 +0100
-+++ ./tests/Composer/Test/PolyfillTestCase.php 2020-10-25 06:23:12.863707931 +0100
-@@ -18,8 +18,33 @@ namespace Composer\Test {
+--- ./tests/Composer/Test/PolyfillTestCase.php.rpm 2020-12-04 08:07:35.947138597 +0100
++++ ./tests/Composer/Test/PolyfillTestCase.php 2020-12-04 08:09:14.344707638 +0100
+@@ -15,10 +15,35 @@ namespace Composer\Test {
+ use PHPUnit\Framework\Constraint\LogicalNot;
use PHPUnit\Framework\Constraint\StringContains;
- use PHPUnit\Framework\Constraint\TraversableContains;
- if (method_exists('PHPUnit\Framework\TestCase', 'assertStringContainsString')) {
+ if (method_exists('PHPUnit\Framework\TestCase', 'assertFileDoesNotExist')) {
- abstract class PolyfillTestCase extends TestCase {}
+ abstract class PolyfillTestCase extends TestCase
+ {
+ }
+ } else if (method_exists('PHPUnit\Framework\TestCase', 'assertStringContainsString')) {
+ abstract class PolyfillTestCase extends TestCase {
+ /**
diff --git a/composer.spec b/composer.spec
index 82041a0..21ad68d 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit cbee637510037f293e641857b2a6223d0ea8008d
+%global gh_commit 62139b2806178adb979d76bd3437534a1a9fd490
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -19,7 +19,7 @@
%global api_version 2.0.0
%global run_version 2.0.0
-%global upstream_version 2.0.7
+%global upstream_version 2.0.8
#global upstream_prever RC2
#global upstream_lower rc2
@@ -318,6 +318,9 @@ exit $ret
%changelog
+* Fri Dec 4 2020 Remi Collet <remi@remirepo.net> - 2.0.8-1
+- update to 2.0.8
+
* Sat Nov 14 2020 Remi Collet <remi@remirepo.net> - 2.0.7-1
- update to 2.0.7