summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-12 19:13:31 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-12 19:13:31 +0100
commit6316a7a79125d960bfa976e3db8a49a27d6f978e (patch)
tree42b7037ea9ec526b849c83a25643f0e764f2a1ce
parentaf13b24d07b0f33bdda434be064c378ac576e60e (diff)
composer-1.0.0-0.20.20160212git25e089e
-rw-r--r--composer-pr4912.patch35
-rw-r--r--composer-pr4913.patch29
-rw-r--r--composer.spec19
3 files changed, 80 insertions, 3 deletions
diff --git a/composer-pr4912.patch b/composer-pr4912.patch
new file mode 100644
index 0000000..75ed845
--- /dev/null
+++ b/composer-pr4912.patch
@@ -0,0 +1,35 @@
+From ae5de98db110857b90f5ff0d62e1d9ea29ec9dd0 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Fri, 12 Feb 2016 17:02:19 +0100
+Subject: [PATCH] make this test more robust, not relying on result order which
+ may vary
+
+---
+ tests/Composer/Test/Repository/PathRepositoryTest.php | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/tests/Composer/Test/Repository/PathRepositoryTest.php b/tests/Composer/Test/Repository/PathRepositoryTest.php
+index e76be2b..ebed4ab 100644
+--- a/tests/Composer/Test/Repository/PathRepositoryTest.php
++++ b/tests/Composer/Test/Repository/PathRepositoryTest.php
+@@ -69,14 +69,18 @@ public function testLoadPackageFromFileSystemWithWildcard()
+ $repositoryUrl = implode(DIRECTORY_SEPARATOR, array(__DIR__, 'Fixtures', 'path', '*'));
+ $repository = new PathRepository(array('url' => $repositoryUrl), $ioInterface, $config, $loader);
+ $packages = $repository->getPackages();
++ $names = array();
+
+ $this->assertEquals(2, $repository->count());
+
+ $package = $packages[0];
+- $this->assertEquals('test/path-versioned', $package->getName());
++ $names[] = $package->getName();
+
+ $package = $packages[1];
+- $this->assertEquals('test/path-unversioned', $package->getName());
++ $names[] = $package->getName();
++
++ sort($names);
++ $this->assertEquals(array('test/path-unversioned', 'test/path-versioned'), $names);
+ }
+
+ /**
diff --git a/composer-pr4913.patch b/composer-pr4913.patch
new file mode 100644
index 0000000..d92d129
--- /dev/null
+++ b/composer-pr4913.patch
@@ -0,0 +1,29 @@
+From abe02595977ade2ec3f7588e5d026b2392757d4d Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Fri, 12 Feb 2016 19:04:43 +0100
+Subject: [PATCH] fix compat with symfony console < 2.8
+
+---
+ src/Composer/IO/ConsoleIO.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Composer/IO/ConsoleIO.php b/src/Composer/IO/ConsoleIO.php
+index f97af2e..1742455 100644
+--- a/src/Composer/IO/ConsoleIO.php
++++ b/src/Composer/IO/ConsoleIO.php
+@@ -139,13 +139,13 @@ private function doWrite($messages, $newline, $stderr, $verbosity)
+ }
+
+ if (true === $stderr && $this->output instanceof ConsoleOutputInterface) {
+- $this->output->getErrorOutput()->write($messages, $newline, $sfVerbosity);
++ $this->output->getErrorOutput()->write($messages, $newline);
+ $this->lastMessageErr = join($newline ? "\n" : '', (array) $messages);
+
+ return;
+ }
+
+- $this->output->write($messages, $newline, $sfVerbosity);
++ $this->output->write($messages, $newline);
+ $this->lastMessage = join($newline ? "\n" : '', (array) $messages);
+ }
+
diff --git a/composer.spec b/composer.spec
index 02556a0..66de997 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,10 +6,10 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit cd21505c8d58499a9b4d38573881cfec49c51ffd
+%global gh_commit 25e089eee90799ed0f6046dfd17521804b113f25
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
-%global gh_date 20160127
+%global gh_date 20160212
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
@@ -18,7 +18,7 @@
Name: composer
Version: 1.0.0
-Release: 0.19.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}%{?dist}
+Release: 0.20.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}%{?dist}
Summary: Dependency Manager for PHP
Group: Development/Libraries
@@ -30,6 +30,10 @@ Source2: %{name}-bootstrap.php
# Use our autoloader, resources path, fix for tests
Patch0: %{name}-rpm.patch
+# See https://github.com/composer/composer/pull/4912
+Patch1: %{name}-pr4912.patch
+# See https://github.com/composer/composer/pull/4913
+Patch2: %{name}-pr4913.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -136,6 +140,8 @@ Documentation: https://getcomposer.org/doc/
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
+%patch1 -p1 -b .rpm
+%patch2 -p1 -b .rpm
find . -name \*.rpm -exec rm {} \; -print
cp -p %{SOURCE1} src/Composer/autoload.php
@@ -221,6 +227,13 @@ rm -rf %{buildroot}
%changelog
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.20.20160212git25e089e
+- new snapshot
+- don't relying on result order which may vary
+ open https://github.com/composer/composer/pull/4912
+- restore compatiblity with symfony < 2.8
+ open https://github.com/composer/composer/pull/4913
+
* Wed Jan 27 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.19.20160127gitcd21505
- new snapshot