summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-13 18:13:41 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-13 18:13:41 +0100
commit19aa30ed2f342f71024899704e3f4d7db180e499 (patch)
treec499cc9e6838f0fc211b949576d7f2fcab537341
parent6316a7a79125d960bfa976e3db8a49a27d6f978e (diff)
composer: test build
-rw-r--r--composer-pr4912.patch35
-rw-r--r--composer-pr4913.patch29
-rw-r--r--composer.spec13
3 files changed, 5 insertions, 72 deletions
diff --git a/composer-pr4912.patch b/composer-pr4912.patch
deleted file mode 100644
index 75ed845..0000000
--- a/composer-pr4912.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From ae5de98db110857b90f5ff0d62e1d9ea29ec9dd0 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 12 Feb 2016 17:02:19 +0100
-Subject: [PATCH] make this test more robust, not relying on result order which
- may vary
-
----
- tests/Composer/Test/Repository/PathRepositoryTest.php | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/tests/Composer/Test/Repository/PathRepositoryTest.php b/tests/Composer/Test/Repository/PathRepositoryTest.php
-index e76be2b..ebed4ab 100644
---- a/tests/Composer/Test/Repository/PathRepositoryTest.php
-+++ b/tests/Composer/Test/Repository/PathRepositoryTest.php
-@@ -69,14 +69,18 @@ public function testLoadPackageFromFileSystemWithWildcard()
- $repositoryUrl = implode(DIRECTORY_SEPARATOR, array(__DIR__, 'Fixtures', 'path', '*'));
- $repository = new PathRepository(array('url' => $repositoryUrl), $ioInterface, $config, $loader);
- $packages = $repository->getPackages();
-+ $names = array();
-
- $this->assertEquals(2, $repository->count());
-
- $package = $packages[0];
-- $this->assertEquals('test/path-versioned', $package->getName());
-+ $names[] = $package->getName();
-
- $package = $packages[1];
-- $this->assertEquals('test/path-unversioned', $package->getName());
-+ $names[] = $package->getName();
-+
-+ sort($names);
-+ $this->assertEquals(array('test/path-unversioned', 'test/path-versioned'), $names);
- }
-
- /**
diff --git a/composer-pr4913.patch b/composer-pr4913.patch
deleted file mode 100644
index d92d129..0000000
--- a/composer-pr4913.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From abe02595977ade2ec3f7588e5d026b2392757d4d Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Fri, 12 Feb 2016 19:04:43 +0100
-Subject: [PATCH] fix compat with symfony console < 2.8
-
----
- src/Composer/IO/ConsoleIO.php | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/Composer/IO/ConsoleIO.php b/src/Composer/IO/ConsoleIO.php
-index f97af2e..1742455 100644
---- a/src/Composer/IO/ConsoleIO.php
-+++ b/src/Composer/IO/ConsoleIO.php
-@@ -139,13 +139,13 @@ private function doWrite($messages, $newline, $stderr, $verbosity)
- }
-
- if (true === $stderr && $this->output instanceof ConsoleOutputInterface) {
-- $this->output->getErrorOutput()->write($messages, $newline, $sfVerbosity);
-+ $this->output->getErrorOutput()->write($messages, $newline);
- $this->lastMessageErr = join($newline ? "\n" : '', (array) $messages);
-
- return;
- }
-
-- $this->output->write($messages, $newline, $sfVerbosity);
-+ $this->output->write($messages, $newline);
- $this->lastMessage = join($newline ? "\n" : '', (array) $messages);
- }
-
diff --git a/composer.spec b/composer.spec
index 66de997..9b0a5cd 100644
--- a/composer.spec
+++ b/composer.spec
@@ -6,10 +6,10 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 25e089eee90799ed0f6046dfd17521804b113f25
+%global gh_commit 7420265c0defbf70bcea598792ab6728216f73b3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 1.0-dev
-%global gh_date 20160212
+%global gh_date 20160213
%global gh_owner composer
%global gh_project composer
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
@@ -30,10 +30,6 @@ Source2: %{name}-bootstrap.php
# Use our autoloader, resources path, fix for tests
Patch0: %{name}-rpm.patch
-# See https://github.com/composer/composer/pull/4912
-Patch1: %{name}-pr4912.patch
-# See https://github.com/composer/composer/pull/4913
-Patch2: %{name}-pr4913.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -140,8 +136,6 @@ Documentation: https://getcomposer.org/doc/
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
-%patch1 -p1 -b .rpm
-%patch2 -p1 -b .rpm
find . -name \*.rpm -exec rm {} \; -print
cp -p %{SOURCE1} src/Composer/autoload.php
@@ -227,6 +221,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Feb 13 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.20.20160213git7420265
+- new snapshot
+
* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.20.20160212git25e089e
- new snapshot
- don't relying on result order which may vary