summaryrefslogtreecommitdiffstats
path: root/atoum.spec
diff options
context:
space:
mode:
Diffstat (limited to 'atoum.spec')
-rw-r--r--atoum.spec32
1 files changed, 15 insertions, 17 deletions
diff --git a/atoum.spec b/atoum.spec
index 943190a..c5229f2 100644
--- a/atoum.spec
+++ b/atoum.spec
@@ -7,11 +7,11 @@
#
# Please preserve changelog entries
#
-%global gh_commit decb381ef771ada37f8850774a9e9770a3da506f
+%global gh_commit 6af6b609a108fd2e63f2f42efbb4f0b799e6c710
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
Name: atoum
-Version: 3.0.0
+Version: 3.1.1
Release: 1%{?dist}
Summary: PHP Unit Testing framework
@@ -58,7 +58,7 @@ Requires: php-xml
# "atoum/stubs": "Provides IDE support (like autocompletion) for atoum",
# "ext-xdebug": "Provides code coverage report (>= 2.3)"
Requires: php-mbstring
-# From phpcompatinfo report for version 3.0.0
+# From phpcompatinfo report for version 3.1.0
Requires: php-cli
Requires: php-date
Requires: php-dom
@@ -141,21 +141,12 @@ cd tests/units
echo "date.timezone=UTC" >php.ini
export PHPRC=$(pwd)/php.ini
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 runner.php --directories . || ret=1
- run=1
-fi
-if which php71; then
- php71 runner.php --directories . || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-php runner.php --directories .
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd runner.php --use-light-report --max-children-number 4 --directories . || ret=1
+ fi
+done
exit $ret
%else
: Tests skipped
@@ -178,6 +169,13 @@ rm -rf %{buildroot}
%changelog
+* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- Update to 3.1.1
+
+* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+- run test suite against SCL if installed
+
* Wed Feb 22 2017 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- update to 3.0.0
- raise dependency on PHP 5.6