summaryrefslogtreecommitdiffstats
path: root/atoum.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-03 13:56:36 +0100
committerRemi Collet <remi@remirepo.net>2020-01-03 13:56:36 +0100
commit039276f64084a4d47eb31412541027898f9765d0 (patch)
treebbb090238bf12197cee9f1b3823732888aa3dcc9 /atoum.spec
parent938ec216ac29cd2ba4bfd9a1ce98edeca46d6bf3 (diff)
v3.4.0
Diffstat (limited to 'atoum.spec')
-rw-r--r--atoum.spec20
1 files changed, 15 insertions, 5 deletions
diff --git a/atoum.spec b/atoum.spec
index cbccd95..657da67 100644
--- a/atoum.spec
+++ b/atoum.spec
@@ -11,15 +11,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c5279d0ecd4e2d53af6b38815db2cafee8fc46b6
+%global gh_commit b6c93433a7b0b92b54c2bb9b0731d71ddc03b365
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
Name: atoum
-Version: 3.3.0
-Release: 1%{?dist}
+Version: 3.4.0
+Release: 2%{?dist}
Summary: PHP Unit Testing framework
-Group: Development/Libraries
License: BSD
URL: http://atoum.org
Source0: https://github.com/%{name}/%{name}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -118,6 +117,9 @@ rm scripts/git/.tag tests/units/classes/scripts/git/.tag
sed -i bin/%{name} \
-e "s|__DIR__ . '/../|'%{_datadir}/%{name}/|"
+sed -i constants.php \
+ -e "s/dev-master/%{version}/"
+
%build
# Empty build section
@@ -147,7 +149,11 @@ for cmd in php php56 php70 php71 php72 php73 php74; do
$cmd runner.php --use-dot-report --max-children-number 4 --directories . || ret=1
fi
done
-exit $ret
+
+if [ $(php -r 'echo PHP_VERSION_ID;') -lt 70400 ]
+then
+ exit $ret
+fi
%else
: Tests skipped
%endif
@@ -164,6 +170,10 @@ exit $ret
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 3.4.0-2
+- update to 3.4.0
+- fix reported version
+
* Fri Mar 16 2018 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0
- undefine __brp_mangle_shebangs