summaryrefslogtreecommitdiffstats
path: root/mod_wsgi.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-13 18:43:31 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-13 18:43:31 +0200
commita388e4a1706ac2cb8a64e465db1d8e99025adc27 (patch)
tree774987ccd2be0b9ea2d88a00917c845550bc8656 /mod_wsgi.spec
reorg repo
Diffstat (limited to 'mod_wsgi.spec')
-rw-r--r--mod_wsgi.spec138
1 files changed, 138 insertions, 0 deletions
diff --git a/mod_wsgi.spec b/mod_wsgi.spec
new file mode 100644
index 0000000..7aa8229
--- /dev/null
+++ b/mod_wsgi.spec
@@ -0,0 +1,138 @@
+%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}
+%{!?_httpd_mmn: %{expand: %%global _httpd_mmn %%(cat %{_includedir}/httpd/.mmn || echo missing-httpd-devel)}}
+%{!?_httpd_confdir: %{expand: %%global _httpd_confdir %%{_sysconfdir}/httpd/conf.d}}
+# /etc/httpd/conf.d with httpd < 2.4 and defined as /etc/httpd/conf.modules.d with httpd >= 2.4
+%{!?_httpd_modconfdir: %{expand: %%global _httpd_modconfdir %%{_sysconfdir}/httpd/conf.d}}
+
+Name: mod_wsgi
+Version: 3.3
+Release: 5%{?dist}.1
+Summary: A WSGI interface for Python web applications in Apache
+
+Group: System Environment/Libraries
+License: ASL 2.0
+URL: http://modwsgi.org
+Source0: http://modwsgi.googlecode.com/files/%{name}-%{version}.tar.gz
+Source1: wsgi.conf
+Patch0: mod_wsgi-3.3-httpd24.patch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: httpd-devel
+BuildRequires: python-devel
+Requires: httpd-mmn = %{_httpd_mmn}
+
+%description
+The mod_wsgi adapter is an Apache module that provides a WSGI compliant
+interface for hosting Python based web applications within Apache. The
+adapter is written completely in C code against the Apache C runtime and
+for hosting WSGI applications within Apache has a lower overhead than using
+existing WSGI adapters for mod_python or CGI.
+
+
+%prep
+%setup -q
+%patch0 -p1 -b .httpd24
+
+%build
+%configure --enable-shared --with-apxs=%{_httpd_apxs}
+make LDFLAGS="-L%{_libdir}" %{?_smp_mflags}
+
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+
+install -d -m 755 $RPM_BUILD_ROOT%{_httpd_modconfdir}
+%if "%{_httpd_modconfdir}" == "%{_httpd_confdir}"
+# httpd <= 2.2.x
+install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/wsgi.conf
+%else
+# httpd >= 2.4.x
+install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_modconfdir}/10-wsgi.conf
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc LICENCE README
+%config(noreplace) %{_httpd_modconfdir}/*.conf
+%{_libdir}/httpd/modules/mod_wsgi.so
+
+
+%changelog
+* Thu Apr 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 3.3-5.1
+- sync with rawhide, rebuild for remi repo
+
+* Wed Mar 28 2012 Remi Collet <RPMS@FamilleCollet.com> - 3.3-5
+- rebuild for remi repo
+
+* Mon Mar 26 2012 Joe Orton <jorton@redhat.com> - 3.3-5
+- move wsgi.conf to conf.modules.d
+
+* Mon Mar 26 2012 Joe Orton <jorton@redhat.com> - 3.3-4
+- rebuild for httpd 2.4
+
+* Tue Mar 13 2012 Joe Orton <jorton@redhat.com> - 3.3-3
+- prepare for httpd 2.4.x
+
+* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Tue Nov 01 2011 James Bowes <jbowes@redhat.com> 3.3-1
+- update to 3.3
+
+* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Tue Jul 27 2010 David Malcolm <dmalcolm@redhat.com> - 3.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
+
+* Tue Mar 9 2010 Josh Kayse <joshkayse@fedoraproject.org> - 3.2-1
+- update to 3.2
+
+* Sun Mar 07 2010 Josh Kayse <joshkayse@fedoraproject.org> - 3.1-2
+- removed conflicts as it violates fedora packaging policy
+
+* Sun Mar 07 2010 Josh Kayse <joshkayse@fedoraproject.org> - 3.1-1
+- update to 3.1
+- add explicit enable-shared
+- add conflicts mod_python < 3.3.1
+
+* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Thu Jul 02 2009 James Bowes <jbowes@redhat.com> 2.5-1
+- Update to 2.5
+
+* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Sun Nov 30 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.3-2
+- Rebuild for Python 2.6
+
+* Tue Oct 28 2008 Luke Macken <lmacken@redhat.com> 2.3-1
+- Update to 2.3
+
+* Mon Sep 29 2008 James Bowes <jbowes@redhat.com> 2.1-2
+- Remove requires on httpd-devel
+
+* Wed Jul 02 2008 James Bowes <jbowes@redhat.com> 2.1-1
+- Update to 2.1
+
+* Mon Jun 16 2008 Ricky Zhou <ricky@fedoraproject.org> 1.3-4
+- Build against the shared python lib.
+
+* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3-3
+- Autorebuild for GCC 4.3
+
+* Sun Jan 06 2008 James Bowes <jbowes@redhat.com> 1.3-2
+- Require httpd
+
+* Sat Jan 05 2008 James Bowes <jbowes@redhat.com> 1.3-1
+- Update to 1.3
+
+* Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.0-1
+- Initial packaging for Fedora
+