summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ImageMagick7.spec94
1 files changed, 28 insertions, 66 deletions
diff --git a/ImageMagick7.spec b/ImageMagick7.spec
index c9f359f..cd9bf9f 100644
--- a/ImageMagick7.spec
+++ b/ImageMagick7.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 7.1.1
-%global Patchlevel 32
+%global Patchlevel 38
%global incsuffixe -7
%global libsuffixe -7.Q16HDRI
%bcond_without tests
@@ -25,6 +25,7 @@
%global with_raw 1
%global with_raqm 1
%global with_gvc 1
+%global with_lqr 1
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
%global with_jxl 1
@@ -32,12 +33,6 @@
%global with_jxl 0
%endif
-%if 0%{?fedora} || 0%{?rhel} >= 8
-%global with_lqr 1
-%else
-%global with_lqr 0
-%endif
-
%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || 0%{?_with_rpmfusion:1}
# from distribution or from rpmfusion, when enabled in mock config
%global with_libheif 1
@@ -72,11 +67,7 @@ BuildRequires: gnupg2
BuildRequires: autoconf automake make
BuildRequires: gcc
BuildRequires: gcc-c++
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: pkgconfig(bzip2)
-%else
-BuildRequires: bzip2-devel
-%endif
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libtiff-4)
@@ -104,33 +95,19 @@ BuildRequires: pkgconfig(lcms2)
BuildRequires: pkgconfig(libraw) >= 0.14.8
%endif
%if %{with_webp}
-%if 0%{?rhel} == 7
-BuildRequires: libwebp7-devel%{?_isa}
-%else
BuildRequires: pkgconfig(libwebp)
%endif
-%endif
%if %{with_jbig}
BuildRequires: jbigkit-devel
%endif
%if %{with_jp2}
-%if 0%{?rhel} == 7
-# See https://github.com/libvips/libvips/issues/764
-# vips pulls poppler (libopenjpeg) and IM (libopenjp2)
-BuildRequires: openjpeg2-static-devel
-%else
BuildRequires: pkgconfig(libopenjp2)
%endif
-%endif
%if %{with_gvc}
BuildRequires: graphviz-devel >= 2.9.0
%endif
%if %{with_raqm}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: pkgconfig(raqm)
-%else
-BuildRequires: libraqm-devel
-%endif
%endif
%if %{with_jxl}
BuildRequires: pkgconfig(libjxl) >= 0.7
@@ -150,10 +127,7 @@ BuildRequires: open-sans-fonts
Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
%if "%{name}" != "%{libname}"
-# This could be improved in the future
-# https://bugzilla.redhat.com/849065
Conflicts: %{libname} < %{epoch}:%{version}
-Conflicts: %{libname}-last < %{epoch}:%{version}
Conflicts: %{libname}6 < %{epoch}:%{version}
Provides: %{libname} = %{epoch}:%{version}-%{release}
Provides: %{libname}%{?_isa} = %{epoch}:%{version}-%{release}
@@ -174,7 +148,7 @@ reduce, or add special effects to an image, and when finished you can
either save the completed work in the original format or a different
one.
-ImageMagick-last includes the command line programs for creating animated or
+%{name} includes the command line programs for creating animated or
transparent .gifs, creating composite images, creating thumbnail images,
and more.
%if "%{name}" != "%{libname}"
@@ -195,36 +169,29 @@ Requires: libjpeg-devel%{?_isa}
Requires: OpenEXR-devel%{?_isa}
Requires: lcms2-devel%{?_isa}
%if %{with_webp}
-%if 0%{?rhel} == 7
-Requires: libwebp7-devel%{?_isa}
-%else
Requires: libwebp-devel%{?_isa}
%endif
-%endif
%if %{with_jbig}
Requires: jbigkit-devel%{?_isa}
%endif
%if %{with_jp2}
-%if 0%{?rhel} != 7
Requires: openjpeg2-devel%{?_isa}
%endif
-%endif
Requires: jasper-devel%{?_isa}
Requires: pkgconfig
%if "%{name}" != "%{libname}"
-Conflicts: %{libname}-devel < %{version}
-Conflicts: %{libname}-last-devel < %{version}
-Conflicts: %{libname}6-devel < %{version}
-Provides: %{libname}-devel = %{version}-%{release}
-Provides: %{libname}-devel%{?_isa} = %{version}-%{release}
+Conflicts: %{libname}-devel < %{epoch}:%{version}
+Conflicts: %{libname}6-devel < %{epoch}:%{version}
+Provides: %{libname}-devel = %{epoch}:%{version}-%{release}
+Provides: %{libname}-devel%{?_isa} = %{epoch}:%{version}-%{release}
%else
-Obsoletes: %{libname}7-devel < %{version}-%{release}
+Obsoletes: %{libname}7-devel <= %{epoch}:%{version}-%{release}
Provides: %{libname}7-devel = %{epoch}:%{version}-%{release}
Provides: %{libname}7-devel%{?_isa} = %{epoch}:%{version}-%{release}
%endif
%description devel
-ImageMagick-last-devel contains the library links and header files you'll
+%{name}-devel contains the library links and header files you'll
need to develop ImageMagick applications. ImageMagick is an image
manipulation program.
@@ -237,19 +204,14 @@ however.
%package libs
Summary: ImageMagick library
%if "%{name}" == "%{libname}"
-Obsoletes: %{libname}7-libs <= %{version}-%{release}
+Obsoletes: %{libname}7-libs <= %{epoch}:%{version}-%{release}
%endif
# default font is OpenSans-Regular
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Recommends: urw-base35-fonts
Recommends: open-sans-fonts
# Additional codecs
Recommends: %{name}-djvu%{?_isa} = %{epoch}:%{version}-%{release}
Recommends: %{name}-heic%{?_isa} = %{epoch}:%{version}-%{release}
-%else
-Requires: urw-base35-fonts
-Requires: open-sans-fonts
-%endif
%description libs
Provides the shared libraries and plugins of %{name}.
@@ -262,11 +224,7 @@ for applications requiring this libraries.
%if %{with_djvu}
%package djvu
Summary: DjVu plugin for ImageMagick
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: pkgconfig(ddjvuapi)
-%else
-BuildRequires: djvulibre-devel
-%endif
Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
%if "%{name}" == "%{libname}"
Obsoletes: %{libname}7-djvu <= %{epoch}:%{version}-%{release}
@@ -286,10 +244,6 @@ for applications requiring this libraries.
%package heic
Summary: HEIC plugin for ImageMagick
BuildRequires: pkgconfig(libheif) >= 1.4.0
-%if 0%{?rhel} == 7
-# ensure we use our on EL-7
-Requires: libheif%{?_isa} >= 1.4.0
-%endif
%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
# x265 HEVC encoder from RPMFusion
Recommends: libheif-freeworld%{?_isa}
@@ -332,7 +286,6 @@ Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%if "%{name}" != "%{libname}"
Conflicts: %{libname}-perl < %{epoch}:%{version}
-Conflicts: %{libname}-last-perl < %{epoch}:%{version}
Conflicts: %{libname}6-perl < %{epoch}:%{version}
Provides: %{libname}-perl = %{epoch}:%{version}-%{release}
Provides: %{libname}-perl%{?_isa} = %{epoch}:%{version}-%{release}
@@ -371,7 +324,6 @@ Requires: %{name}-c++%{?_isa} = %{epoch}:%{version}-%{release}
Requires: %{name}-devel%{?_isa} = %{epoch}:%{version}-%{release}
%if "%{name}" != "%{libname}"
Conflicts: %{libname}-c++-devel < %{epoch}:%{version}
-Conflicts: %{libname}-last-c++-devel < %{epoch}:%{version}
Conflicts: %{libname}6-c++-devel < %{epoch}:%{version}
Provides: %{libname}-c++-devel = %{epoch}:%{version}-%{release}
Provides: %{libname}-c++-devel%{?_isa} = %{epoch}:%{version}-%{release}
@@ -564,14 +516,6 @@ the new location (e.g. httpd, php-fpm).
EOF
fi
-%if 0%{?fedora} < 28 && 0%{?rhel} < 8
-%post -p /sbin/ldconfig
-%post c++ -p /sbin/ldconfig
-
-%postun -p /sbin/ldconfig
-%postun c++ -p /sbin/ldconfig
-%endif
-
%files
%{_bindir}/[a-z]*
@@ -656,6 +600,24 @@ fi
%changelog
+* Mon Sep 2 2024 Remi Collet <remi@remirepo.net> - 7.1.1.38-1
+- update to version 7.1.1 patch level 38
+
+* Mon Aug 26 2024 Remi Collet <remi@remirepo.net> - 7.1.1.37-1
+- update to version 7.1.1 patch level 37
+
+* Mon Jul 29 2024 Remi Collet <remi@remirepo.net> - 7.1.1.36-1
+- update to version 7.1.1 patch level 36
+
+* Mon Jul 15 2024 Remi Collet <remi@remirepo.net> - 7.1.1.35-1
+- update to version 7.1.1 patch level 35
+
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 7.1.1.34-1
+- update to version 7.1.1 patch level 34
+
+* Mon May 27 2024 Remi Collet <remi@remirepo.net> - 7.1.1.33-1
+- update to version 7.1.1 patch level 33
+
* Mon May 13 2024 Remi Collet <remi@remirepo.net> - 7.1.1.32-1
- update to version 7.1.1 patch level 32