summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 16:52:53 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 16:52:53 +0200
commitef005144de54daa3afbabd970a809b6cb4ef8e94 (patch)
tree8dd7f64e3c16ab998bde5430403efaec461783fd
parent2f242d7c14199f9d2f24ce1ae29a6f6b91f1af77 (diff)
- update to version 7.0.8 patch level 45HEADmaster
- add HEIC support using libheif from RPMFusion in optional heic subpackage
-rw-r--r--ImageMagick7.spec54
1 files changed, 46 insertions, 8 deletions
diff --git a/ImageMagick7.spec b/ImageMagick7.spec
index 6cd2c89..7bc592d 100644
--- a/ImageMagick7.spec
+++ b/ImageMagick7.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 7.0.8
-%global Patchlevel 44
+%global Patchlevel 45
%global incsuffixe -7
%global libsuffixe -7.Q16HDRI
%global with_tests 0%{!?_without_tests:1}
@@ -50,6 +50,9 @@
%global with_gvc 1
+# from mock config, when rpmfusion enabled
+%global with_libheif 0%{?_with_rpmfusion:1}
+
%global libname ImageMagick
# No need to relocate for now, as ImageMagick-7 is not ImageMagick-6
@@ -89,13 +92,6 @@ BuildRequires: pkgconfig(zlib)
BuildRequires: pkgconfig(libzstd)
BuildRequires: perl-devel
BuildRequires: ghostscript-devel
-%if %{with_djvu}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: pkgconfig(ddjvuapi)
-%else
-BuildRequires: djvulibre-devel
-%endif
-%endif
BuildRequires: libwmf-devel
BuildRequires: pkgconfig(jasper)
BuildRequires: libtool-ltdl-devel
@@ -247,6 +243,11 @@ for applications requiring this libraries.
%if %{with_djvu}
%package djvu
Summary: DjVu plugin for ImageMagick
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: pkgconfig(ddjvuapi)
+%else
+BuildRequires: djvulibre-devel
+%endif
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%if "%{name}" == "%{libname}"
Obsoletes: %{libname}7-djvu <= %{version}-%{release}
@@ -262,6 +263,25 @@ for applications requiring this libraries.
%endif
+%if %{with_libheif}
+%package heic
+Summary: HEIC plugin for ImageMagick
+BuildRequires: pkgconfig(libheif)
+Requires: %{name}-libs%{?_isa} = %{version}-%{release}
+%if "%{name}" == "%{libname}"
+Obsoletes: %{libname}7-heic <= %{version}-%{release}
+%endif
+
+%description heic
+This packages contains a plugin for ImageMagick which makes it possible to
+save and load HEIC files from ImageMagick and libMagickCore using applications.
+%if "%{name}" != "%{libname}"
+This package could be installed beside official RPM of ImageMagick-heic
+for applications requiring this libraries.
+%endif
+%endif
+
+
%package doc
Summary: ImageMagick html documentation
%if "%{name}" == "%{libname}"
@@ -404,6 +424,11 @@ cp -p Magick++/demo/*.cpp Magick++/demo/*.miff Magick++/examples
%if %{with_gvc}
--with-gvc \
%endif
+%if %{with_libheif}
+ --with-heif \
+%else
+ --without-heif \
+%endif
--with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'" \
--without-dps \
%if %{move}
@@ -527,6 +552,9 @@ fi
%if %{with_djvu}
%exclude %{_libdir}/%{libname}-%{VER}/modules-Q16HDRI/coders/djvu.*
%endif
+%if %{with_libheif}
+%exclude %{_libdir}/%{libname}-%{VER}/modules-Q16HDRI/coders/heic.*
+%endif
%files devel
%{_bindir}/MagickCore-config
@@ -550,6 +578,11 @@ fi
%{_libdir}/%{libname}-%{VER}/modules-Q16HDRI/coders/djvu.*
%endif
+%if %{with_libheif}
+%files heic
+%{_libdir}/%{libname}-%{VER}/modules-Q16HDRI/coders/heic.*
+%endif
+
%files doc
%if %{move}
%doc %{_datadir}/%{name}/doc/%{libname}%{?incsuffixe}
@@ -578,6 +611,11 @@ fi
%changelog
+* Mon May 13 2019 Remi Collet <remi@remirepo.net> - 7.0.8.45-1
+- update to version 7.0.8 patch level 45
+- add HEIC support using libheif from RPMFusion
+ in optional heic subpackage
+
* Mon May 6 2019 Remi Collet <remi@remirepo.net> - 7.0.8.44-1
- update to version 7.0.8 patch level 44