summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-30 15:39:31 +0100
committerRemi Collet <remi@remirepo.net>2017-11-30 15:39:31 +0100
commit31ae368adc925c66ebf403e40c6afa10c1727804 (patch)
tree35a100ef2819793c4286e21c584f62b8bcbd913d
parent6159dae2b6d4e2d53580726000ed980a515e8461 (diff)
add upstream patch for #888
-rw-r--r--4674b9a584fcb9ca5151c2c8b9104b5877a81d0c.patch67
-rw-r--r--ImageMagick6.spec8
2 files changed, 74 insertions, 1 deletions
diff --git a/4674b9a584fcb9ca5151c2c8b9104b5877a81d0c.patch b/4674b9a584fcb9ca5151c2c8b9104b5877a81d0c.patch
new file mode 100644
index 0000000..3bf4a3c
--- /dev/null
+++ b/4674b9a584fcb9ca5151c2c8b9104b5877a81d0c.patch
@@ -0,0 +1,67 @@
+From 4674b9a584fcb9ca5151c2c8b9104b5877a81d0c Mon Sep 17 00:00:00 2001
+From: Cristy <urban-warrior@imagemagick.org>
+Date: Thu, 30 Nov 2017 09:22:48 -0500
+Subject: [PATCH] https://github.com/ImageMagick/ImageMagick/issues/888
+
+---
+ coders/dng.c | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/coders/dng.c b/coders/dng.c
+index 069104dee9..17791019e0 100644
+--- a/coders/dng.c
++++ b/coders/dng.c
+@@ -161,25 +161,24 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info)
+
+ (void) SetImageProperty(image,"dng:make",raw_info->idata.make);
+ (void) SetImageProperty(image,"dng:camera.model.name",raw_info->idata.model);
+- (void) SetImageProperty(image,"dng:software",raw_info->idata.software);
+ (void) FormatMagickTime(raw_info->other.timestamp,MagickPathExtent,timestamp);
+ (void) SetImageProperty(image,"dng:create.date",timestamp);
++ (void) SetImageProperty(image,"dng:f.number",property);
++ (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
++ raw_info->other.iso_speed);
+ #if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,18)
++ (void) SetImageProperty(image,"dng:software",raw_info->idata.software);
+ if (*raw_info->shootinginfo.BodySerial != '\0')
+ (void) SetImageProperty(image,"dng:serial.number",
+ raw_info->shootinginfo.BodySerial);
+ (void) FormatLocaleString(property,MagickPathExtent,"%0.2f",
+ raw_info->other.FlashEC);
+ (void) SetImageProperty(image,"dng:flash.exposure.compensation",property);
+-#endif
+ (void) FormatLocaleString(property,MagickPathExtent,"1/%0.1f",
+ 1.0/raw_info->other.shutter);
+ (void) SetImageProperty(image,"dng:exposure.time",property);
+ (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
+ raw_info->other.aperture);
+- (void) SetImageProperty(image,"dng:f.number",property);
+- (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
+- raw_info->other.iso_speed);
+ (void) SetImageProperty(image,"dng:iso.setting",property);
+ (void) FormatLocaleString(property,MagickPathExtent,"%0.1f",
+ raw_info->lens.EXIF_MaxAp);
+@@ -212,6 +211,7 @@ static void SetDNGProperties(Image *image,const libraw_data_t *raw_info)
+ (void) FormatLocaleString(property,MagickPathExtent,"%d mm",
+ raw_info->lens.FocalLengthIn35mmFormat);
+ (void) SetImageProperty(image,"dng:focal.length.in.35mm.format",property);
++#endif
+ }
+ #endif
+
+@@ -382,6 +382,7 @@ static Image *ReadDNGImage(const ImageInfo *image_info,ExceptionInfo *exception)
+ profile=DestroyStringInfo(profile);
+ }
+ }
++#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,18)
+ if (raw_info->idata.xmpdata)
+ {
+ profile=BlobToStringInfo(raw_info->idata.xmpdata,
+@@ -392,6 +393,7 @@ static Image *ReadDNGImage(const ImageInfo *image_info,ExceptionInfo *exception)
+ profile=DestroyStringInfo(profile);
+ }
+ }
++#endif
+ SetDNGProperties(image,raw_info);
+ libraw_close(raw_info);
+ return(image);
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index f1a73f6..b9ab03c 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -73,13 +73,15 @@ Name: %{libname}
Name: %{libname}6
%endif
Version: %{VER}.%{Patchlevel}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: An X application for displaying and manipulating images
Group: Applications/Multimedia
License: ImageMagick
Url: http://www.imagemagick.org/
Source0: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
+Patch0: https://github.com/ImageMagick/ImageMagick/commit/4674b9a584fcb9ca5151c2c8b9104b5877a81d0c.patch
+
BuildRequires: bzip2-devel, freetype-devel, libjpeg-devel, libpng-devel
BuildRequires: libtiff-devel, giflib-devel, zlib-devel
%if 0%{?fedora} >= 7 || 0%{?rhel} >= 6
@@ -329,6 +331,7 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
+%patch0 -p1 -b.upstream
# for %%doc
mkdir Magick++/examples
@@ -571,6 +574,9 @@ fi
%changelog
+* Thu Nov 30 2017 Remi Collet <remi@remirepo.net> - 6.9.9.24-2
+- add upstream patch for #888
+
* Thu Nov 30 2017 Remi Collet <remi@remirepo.net> - 6.9.9.24-1
- update to version 6.9.9 patch level 24
- open https://github.com/ImageMagick/ImageMagick/issues/888